1. 云栖社区>
  2. >
  3. 正文

Elasticfusion 配置

作者:用户 来源:互联网 时间:2018-08-31 11:19:45

ElasticFusionubuntu140464位三维slam

Elasticfusion 配置 - 摘要: 本文讲的是Elasticfusion 配置, 电脑配置是:ubuntu14.04(64位)+GTX1070+CPU(i7) 首先,在已装有SSD目标检测的条件下(此时cuda8.0等都已经装好了)进行的Elasticfusion的安装配置 然后,按照官网

电脑配置是:ubuntu14.04(64位)+GTX1070+CPU(i7)

首先,在已装有SSD目标检测的条件下(此时cuda8.0等都已经装好了)进行的Elasticfusion的安装配置

然后,按照官网

https://github.com/mp3guy/Elasticfusion

1、安装OpenNI2

如果在安装依赖库时找不到库,那么换源在进行。执行最后一步的时候failed,跳过,没所谓

  sudo apt-get install g++
  sudo apt-get install python
  sudo apt-get install libusb-1.0-0-dev
  sudo apt-get install libudev-dev
  sudo apt-get install openjdk-6-jdk
  sudo apt-get install freeglut3-dev
  sudo apt-get install doxygen
  sudo apt-get install graphviz
cd OpenNI-master;make

2、安装Pangolin

同样按照链接里给出的,成功.pangolin是岁OpenGL输入输出和视频显示的库,可用于3D视觉和3D导航的视觉图。百度搜索"pangolin学习”有这方面的资料

sudo apt-get install libglew-dev

git clone https://github.com/stevenlovegrove/Pangolin.git
cd Pangolin
mkdir build
cd build
cmake ..
cmake --build .

3、安装依赖项

sudo apt-get install -y cmake-qt-gui git build-essential libusb-1.0-0-dev libudev-dev openjdk-7-jdk freeglut3-dev libglew-dev cuda-7-5 libsuitesparse-dev libeigen3-dev zlib1g-dev libjpeg-dev

其中,cuda-7-5不要安装

接着,按照如下博客进行编译

http://blog.csdn.net/cattylsy/article/details/52239590

4、安装cmake

直接在ubuntu软件中心下载安装,但是配置Elastic Fusion需要升级到3.2,否则自带的是2.8

sudo apt-get install build-essential  
wget http://www.cmake.org/files/v3.2/cmake-3.2.2.tar.gz  
tar xf cmake-3.2.2.tar.gz  
cd cmake-3.2.2  
./configure  
make  
sudo make install  
运行cmake --version查看版本

如果提示找不到bin/cmake,那么sudo apt-get upgrade就可以了

5、配置kinect环境

我用的是kinect1,安装kinect1的驱动 ubuntu 下的kinect1的驱动我知道的有两种方式: 
 -----openNI+sensor+NITE(可选) 

 -----openNI2+libFreenect 我使用的是这一种。

前面已经安装好OpenNI2,接着安装libfreenect

进入openni2目录    cd OpenNI2
git clone https://github.com/OpenKinect/libfreenect.git  
cd libfreenect  
mkdir build; cd build  
cmake .. -DBUILD_OPENNI2_DRIVER=ON  
make  
cp -L lib/OpenNI2-FreenectDriver/libFreenectDriver.so ${OPENNI2_DIR}/Bin/x64-Release/OpenNI2/Drivers   #将驱动拷贝到OpenNI2的解压文件夹下,OPENNI2_DIR:OpenNI2的解压文件夹  
sudo cp libfreenect/platform/linux/udev/51-kinect.rules /etc/udev/rules.dsudo reboot 插上kinect后,使用lsusb命令查看确保有以下三个: 
  
Xbot camera
Xbot motor

Xbot audio

安装成功检查:

cd ${OPENNI2_DIR}/Bin/x64-Release/  
./NiViewer  

遇到错误:发现不了设备

错误原因:usb冲突,电脑的前面的两个usb是一根总线,后面的共用一根总线,一开始我是用hub集线器引出来,鼠标和kinect1都插在hub上,造成冲突,换个usb插头即可

6、安装PCL

sudo add-apt-repository ppa:v-launchpad-jochen-sprickerhof-de/pcl  
sudo apt-get update  
sudo apt-get install libpcl-all  

7、安装opengl

sudo apt-get install build-essential  
sudo apt-get install libgl1-mesa-dev  
sudo apt-get install libglu1-mesa-dev  
sudo apt-get install freeglut3-dev  

8、编译

注意源码里有三个项目,Core、GPUTest和GUI

如果要使用作者的程序,则需要把三个项目安装顺序依次配置成功

cd ../Core  
mkdir build  
cd build  
cmake -D CUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda-7.5 ../src  
make -j8  
cd ../../GPUTest  
mkdir build  
cd build  
cmake -D CUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda-7.5 ../src  
make -j8  
cd ../../GUI  
mkdir build  
cd build  
cmake -D CUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda-7.5 ../src  
make -j8  
之后就能在GUI/build中看到可执行项ElasticFusion。直接调用以下命令,默认从kinect1中获取图像并开始三位重建
./ElasticFusion  
这时出现错误:

error: GLSL 3.30 is not supported. Supported versions are: 1.00 ES, 1.10, 1.20, and 1.30

这是一个关于显卡驱动支持的错误. 解决办法:

.查看一些参数
sudo dpkg --list | grep nvidia  不显示NVIDIA的版本,说明有问题
lspci | grep -i nvidia   设备里的确有nvidia显卡

选择在终端重装nvidia驱动,而不是手动

sudo apt-get remove --purge nvidia-*
(***提示cmake-qt-gui依赖cmake 2.8出错,卸载cmake-qt-gui。卸载后cmake命令没出错,其他情况会不会出错有待观察)
sudo add-apt-repository ppa:xorg-edgers/ppa -y
sudo apt-get update
sudo apt-get install nvidia-367
查看安装的版本
sudo dpkg --list | grep nvidia 这时就有nvidia的版本信息了

Elasticfusion 配置

sudo modprobe nvidia-384 (这里nvidia-384是Tab键补全而来的) 手动启用nvidia显卡

然后再次运行

./ElasticFusion  
成功。。。


Elasticfusion 配置








以上是Elasticfusion 配置的全部内容,在云栖社区的博客、问答、公众号、人物、课程等栏目也有Elasticfusion 配置的相关内容,欢迎继续使用右上角搜索按钮进行搜索ElasticFusion , ubuntu140464位 三维slam ,以便于您获取更多的相关知识。