1. 云栖社区>
  2. PHP教程>
  3. 正文

Supported Versions of PHP

作者:用户 来源:互联网 时间:2017-12-01 14:17:52

Supported Versions of PHP - 摘要: 本文讲的是Supported Versions of PHP, PHP 5.5 is already in the “security support only” category: Each release branch of PHP is fully supported for two

PHP 5.5 is already in the “security support only” category:

Each release branch of PHP is fully supported for two years from its initial stable release. During this period, bugs and security issues that have been reported are fixed and are released in regular point releases.

After this two year period of active support, each branch is then supported for an additional year for critical security issues only. Releases during this period are made on an as-needed basis: there may be multiple point releases, or none, depending on the number of reports.

From PHP: Supported Versions.

The issue of how long to support previous releases is a big deal. There is already plenty of work to do in terms of pushing forward on new releases, working on previous releases just adds to the stack.

When possible the biggest help to everyone is making it clear when and for how long previous releases are going to be supported. This is something that Ubuntu has done a good job at. They established a pattern of LTS ( Long Term Support ) vs regular releases, making the expectations clear ( though their move to reduce non-LTS release support from 18 to 9 monthsdefinitely caused confusion/problems for people ).

If you want your favorite project to support previous releases longer, understand that means getting involved and providing resources ( time, money, people ).

以上是云栖社区小编为您精心准备的的内容,在云栖社区的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索,以便于您获取更多的相关知识。