1. 云栖社区>
  2. PHP教程>
  3. 正文

php5.3.0以上出现Strict Standards错误

作者:用户 来源:互联网 时间:2017-12-01 15:49:50

php错误Strict5.3出现

php5.3.0以上出现Strict Standards错误 - 摘要: 本文讲的是php5.3.0以上出现Strict Standards错误, 在运行PHP软件时,若是碰到类似的错误,“Strict Standards”,不是错误,而是PHP5.3和之前的版本不太兼容。5.3之后的版本规定声明须要在应用之前。 批改php.ini就可以解决,其实就是不显示出这个异常:原php.in


在运行PHP软件时,若是碰到类似的错误,“Strict Standards”,不是错误,而是PHP5.3和之前的版本不太兼容。5.3之后的版本规定声明须要在应用之前。


批改php.ini就可以解决,其实就是不显示出这个异常:

原php.ini
error_reporting = E_ALL | E_STRICT
改为
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

以上是云栖社区小编为您精心准备的的内容,在云栖社区的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索php , 错误 , Strict , 5.3 , 出现 , ,以便于您获取更多的相关知识。