1. 云栖社区>
  2. PHP教程>
  3. 正文

当前版本的memcache不兼容PHP5.4.4

作者:用户 来源:互联网 时间:2017-12-01 20:40:36

php兼容版本memcache5.4当前

当前版本的memcache不兼容PHP5.4.4 - 摘要: 本文讲的是当前版本的memcache不兼容PHP5.4.4, 折腾了好几天,PHP编译了几十次,试了memcache2.2.6和3.0.6两个版本,查了无数资料,也没能解决问题。应该不止是5.4.4,5.4.X目前还都不行。直接编译memcache会提示:memcache.c:721: error:


折腾了好几天,PHP编译了几十次,试了memcache2.2.6和3.0.6两个版本,查了无数资料,也没能解决问题。
应该不止是5.4.4,5.4.X目前还都不行。
直接编译memcache会提示:memcache.c:721: error: too few arguments to function ‘zend list insert’。
找到个解决方案说直接修改memcache源码后编译的,编译倒能成功。但APACHE2.4.2的错误日志:memcache.so: undefined symbol: executor_globals in Unknown on line 0。
一怒之下换了nginx1.2.2,但是PHP无法实例化Memcache类。
还有人讲静态编译的,把 memcache 源码放到php/ext下,指定参数跟PHP一起编译。倒也能编译成功,就是编译好之后根本没找着memcache.so在什么地方。
最后还是用PHP5.3.14了事。期待memcache尽快更新版本。

以上是云栖社区小编为您精心准备的的内容,在云栖社区的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索php , 兼容 , 版本 , memcache , 5.4 当前 ,以便于您获取更多的相关知识。