1. 云栖社区>
  2. PHP教程>
  3. 正文

配置远程服务器php环境-php

作者:用户 来源:互联网 时间:2017-12-01 19:56:52

php服务器远程配置环境

配置远程服务器php环境-php - 摘要: 本文讲的是配置远程服务器php环境-php,配置远程服务器php环境---php 1.下载php:http://cn2.php.net/get/php-5.5.8.tar.gz/from/a/mirror 2.安装#./configure --disable-rpath --p

配置远程服务器php环境---php

1.下载php:http://cn2.php.net/get/php-5.5.8.tar.gz/from/a/mirror

2.安装

#./configure --disable-rpath --prefix=/usr/local/php5 --with-mysql=/usr/local/mysql --withz apxs2=/usr/local/apache/bin/apxs --with-mysql --disable-fileinfo#make#make install

?3.配置

?

?

#cd /usr/local/src/php-5.5.8#cp php.ini-development /usr/local/php5/lib/php.ini#vi /usr/local/apache/conf/httpd.conf

? ?修改apache配置文件

?

? (1)ServerName??192.168.0.205:80

? (2)添加AddType application/x-httpd-php .php

? ?(3)查找 DirectoryIndex index.html 添加index.php中间加,号

?

#cd /usr/local/apache/bin/#./apachectl restart

?

4.遇到的问题及解决办法

? (1)make: *** No targets specified and no makefile found. Stop.

?

1、wget http://ftp.gnu.org/pub/gnu/ncurses/ncurses-5.6.tar.gz2.、tar zxvf ncurses-5.6.tar.gz3、 ./configure -prefix=/usr/local -with-shared -without-debug4、make5、make install

?

? (2)configure error xml2-config not found. please check your libxml2 installation

?

检查是否安装了libxm包# rpm -qa |grep libxml2libxml2-2.6.26-2.1.12libxml2-python-2.6.26-2.1.12重新安装libxml2和libxml2-devel包, yum安装的时候发现新版本会提示更新,需要更新的可以更新,不要跳过就行了。# yum install libxml2# yum install libxml2-devel -y安装完之后查找xml2-config文件是否存在# find / -name "xml2-config"/usr/bin/xml2-config

??参见:http://blog.chinaunix.net/uid-26719405-id-3409842.html

? (3)configure: error: Cannot find MySQL header files under /usr/include/mysql.

?

#find / -name mysql.h //查找是否存在#yum install MySQL-devel*注意:安装完成后,要在./configure 后多加一条--with-mysql路径

? ?参见:http://blog.csdn.net/sunnyzhangwenhan/article/details/8517463

?

(4)virtual memory exhausted: Cannot allocate memory

?

# dd if=/dev/zero of=/swap bs=1024 count=1MFormat the swap file:# mkswap /swapEnable the swap file:# swapon /swapEnable swap on boot:# echo "/swap swap swap sw 0 0" >> /etc/fstab

? ?(5)make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1

? ?这是由于内存小于1G所导致.在./configure加上选项:–disable-fileinfo

?

?

?

?

?

?

以上是云栖社区小编为您精心准备的的内容,在云栖社区的博客、问答、公众号、人物、课程等栏目也有的相关内容,欢迎继续使用右上角搜索按钮进行搜索php , 服务器 , 远程 , 配置 环境 ,以便于您获取更多的相关知识。

弹性可伸缩的计算服务,助您降低 IT 成本,提升运维效率

40+云计算产品,6个月免费体验

现在注册,免费体验40+云产品,及域名优惠!

云服务器9.9元/月,大学必备