1. 云栖社区>
  2. PHP教程>
  3. 正文

PHP不支持高版本的openssl

作者:用户 来源:互联网 时间:2017-12-01 16:11:37

phpopenssl版本支持

PHP不支持高版本的openssl - 摘要: 本文讲的是PHP不支持高版本的openssl, PHP不支持高版本的openssl 现有一台LNMP测试环境机器,Centos 6.9 先前升级过openssl版本由1.0.1e升级到1.1.0f, 因工作需求,升级php版本,升级到5.6.30,编译php中指定--with-open


PHP不支持高版本的openssl

现有一台LNMP测试环境机器,Centos 6.9 先前升级过openssl版本由1.0.1e升级到1.1.0f,

因工作需求,升级php版本,升级到5.6.30,编译php中指定--with-openssl报错,搜了下资料,php不支持高版本openssl

../../mysys_ssl/libmysys_ssl.a(my_crypt.cc.o):/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_crypt.cc:41:moreundefinedreferencesto`EVP_CIPHER_CTX_cleanup'follow
collect2:error:ldreturned1exitstatus
unittest/mysys/CMakeFiles/aes-t.dir/build.make:105:recipefortarget'unittest/mysys/aes-t'failed
make[2]:***[unittest/mysys/aes-t]Error1
CMakeFiles/Makefile2:916:recipefortarget'unittest/mysys/CMakeFiles/aes-t.dir/all'failed
make[1]:***[unittest/mysys/CMakeFiles/aes-t.dir/all]Error2
Makefile:160:recipefortarget'all'faile

解决方法:PHP编译换成低版本openssl环境或者不使用openssl参数(--with-openssl)注:php编译(--with-openssl)不能像nginx那样指定opensll源码目录,必须指定的是已编译安装好的openssl目录

参考资料:https://bbs.vpser.net/viewthread.php?tid=15744&highlight=%E4%BA%AC%E4%B8%9C%E4%BA%91


以上是PHP不支持高版本的openssl的全部内容,在云栖社区的博客、问答、公众号、人物、课程等栏目也有其他相关内容,欢迎继续使用右上角搜索按钮进行搜索php , openssl , 版本 支持 ,以便于您获取更多的相关知识。