HDU1702

简介: ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1789    Accepted Submission(s): 963 Problem Description

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1789    Accepted Submission(s): 963


Problem Description
ACboy was kidnapped!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
 

Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
 

Sample Input
 
 
4 4 FIFO IN 1 IN 2 OUT OUT 4 FILO IN 1 IN 2 OUT OUT 5 FIFO IN 1 IN 2 OUT OUT OUT 5 FILO IN 1 IN 2 OUT IN 3 OUT
 

Sample Output
 
 
1 2 2 1 1 2 None 2 3
 

Source
#include <queue>
#include <stack>
#include <string>
#include<stdio.h>
#include<iostream>
using namespace std;

int main()

{    int t,n,temp,i;

    scanf("%d",&t);

    while(t--)

    {    string str,str1;

        queue<int>Q;
        stack<int>S;
        scanf("%d",&n);
        cin>>str;
        for(i=0; i<n; i++)
        {    if(str=="FIFO")
            {    cin>>str1;
                if(str1=="IN")
                {    scanf("%d",&temp);
                    Q.push(temp);
                }
                if(str1=="OUT")
                {    if(Q.empty())
                        printf("None\n");
                    else      {
                        printf("%d\n",Q.front());
                        Q.pop();
                    }
                }
            }            else
            {    cin>>str1;
                if(str1=="IN")
                {    scanf("%d",&temp);
                    S.push(temp);
                }
                if(str1=="OUT")
                {    if(S.empty())
                        printf("None\n");
                    else {
                        printf("%d\n",S.top());
                        S.pop();
                    }
                }
            }
        }
    }
    return 0;
}


目录
相关文章
|
人工智能 Java
hdu 1712 ACboy needs your help
ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。
113 0
HDU2203亲和串
博客水平见水平......目前阶段就是这么菜,我会好好努力的!毕业直接拿到阿里offer!
1199 0
HDU 2549 壮志难酬
壮志难酬 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 12541    Accepted Submission(s): 4166 Problem Description 话说MCA山上各路豪杰均出山抗敌,去年曾在江湖威名显赫的,江湖人称的甘露也不甘示弱,“天将降大任于斯人也,必先劳其筋骨,饿其体肤,空乏其身”他说。
1002 0
|
人工智能
|
机器学习/深度学习 人工智能