Composer 基本使用

  1. 云栖社区>
  2. 博客>
  3. 正文

Composer 基本使用

ap5980n2w 2019-08-16 13:25:35 浏览251
展开阅读全文

基本用法

引言

介绍基本用法,我们将安装 monolog/monolog 日志库作为范例。如果你还没有安装 Composer,请参阅 Composer 安装 章节。

注意:为简便起见,我们假定你已经 本地 安装了 Composer。

composer.json:项目设置

若要在项目中使用 Composer 你需要一个 composer.json 文件。该文件描述了你的项目依赖关系和其他元数据。

require 键

首先(通常也是唯一)应该做的事情就是在你的 composer.json 文件中定义好 require 键。你应该简要告诉 Composer 你的项目所依赖的包有哪些。

{
    "require": {
        "monolog/monolog": "1.0.*"
    }
}

如上所示, require 获取了一个包名称 (例如 monolog/monolog)映射到版本约束 (例如 1.0.*)的 json 对象。

Composer 使用该信息去「版本库」中搜索,你在 Composer.json 中注册的 repositories 键所指定的版本仓库中的相关合适的文件,或是在 Packagist 中默认的包库。在上述示例中,因为没有其他在 composer.json 文件中注册的版本库信息,所以它认为 monolog/monolog 包默认是在 Packagist 中。(更多 Packagist 信息请参阅如下,或在此阅读更多相关信息。

包名称

包名由供应商名称和项目名称组成。通常情况下,这些名称是相同的,供应商名称的存在则很好的解决了命名冲突。 例如,它允许两个不同的人创建同样名为 Json 的库。 可以命名为 igorw/json 和 seldaek/json。

在这里您可以阅读更多有关发布包和包命名的内容。

注意,您还可以指定 “平台包” 作为依赖项,这允许您自定义某些版本的服务器软件。请参阅下面的平台软件包

包版本约束

在上面的示例中,我们引入的 monolog 版本指定为 1.0.*。这表示任何从 1.0 开始的开发分支,它将会匹配 大于或等于 1.0 且小于 1.1 的版本。

请阅读关于版本的更深入信息,如何相互关联或如何版本控制。

Composer 如何下载正确的文件?当您在 composer.json 中指定一个依赖项时, Composer 首先获取您所请求的包的名称,并在已使用库密钥注册的任何存储库中搜索它。如果您没有注册任何额外的存储库,或者它在您指定的存储库中找不到具有该名称的包,则返回到 Packagist (下面是详细说明)。

当 Composer 在打包器中找到正确的包时,或者在已指定的包的储存库,它使用包的 VCS (即分支和标签)的版本化特性来尝试找到您指定的版本约束的最佳匹配。请务必阅读有关版本和包声明的文章。

注意:如果您试图获取一个包,但 Composer 抛出关于包稳定性的错误,则您指定的版本可能无法满足默认的最小稳定性要求。默认情况下,只有在搜索 VCS 中的有效包版本时才会考虑稳定的版本。

如果你也想获得 DEV、Alpha、Beta 或 RC 版本。请阅读更多关于稳定标志和 minimum-stability key on the schema page。

安装依赖关系

使用 install命令为你的项目安装已经定义好的依赖关系

php composer.phar install

运行该命令,composer 会根据情况通过以下两种方式中的一种进行安装

非 composer.lock 安装

如果你之前从未运行过命令就不会出现 composer.lock 文件,Composer 只会解析你在 composer.json 文件中列出的依赖关系并且下载最近版本到你项目 vendor 目录中 ( vendor 是项目中存放所有第三方代码的常规目录)。在我们上面的例子中,你最终会在 vendor/monolog/monolog/ 目录中看到所有 Monolog 的源文件。如果 Monolog 有任何依赖,也将会出现在 vendor/ 中.

提示:如果你的项目中使用了 git, 或许你希望将 vendor 添加到 .gitignore 中。因为将所有第三方包添加到版本库里面看起来很傻。

当 Composer 完成安装后,它将把所有下载的包和确切的版本信息写入到 composer.lock 文件,以此来锁定项目中第三方包的版本。你应该将 composer.lock 放在项目仓库中,以便该项目所有成员都能锁定在依赖关系相同的版本

使用 composer.lock 文件安装

这里来到了第二种安装方式。如果你在运行 composer install 命令之前已经存在了 composer.lock 和 composer.json 文件, 这意味着你之前使用了 install 命令, 或者项目中的其他成员使用了 install 命令并将 composer.lock 文件提交至了项目中 (这是非常好的)。

无论使用哪种方式,存在 composer.lock 文件时使用 install 命令安装依赖时 composer.lock 都会解析并安装你在 composer.json 中所列出来的依赖,但是 Composer 会严格使用 composer.lock 文件列出来的版本来确保项目中的所有成员所安装的版本都是一致的。因此,你可以获得 composer.json 文件列出的所有文件,但是与此同时他们可能并不是最新的可用版本 (一些在 composer.lock 文件中列出的依赖可能会在这个文件创建之后释放了新的版本)。这个是设计上的,这样的设计可以确保你的项目不会因为一些依赖的改变而崩溃。

提交你的 composer.lock 文件至版本控制工具

将此文件提交至 VC 是非常重要的。因为它可以确保项目中的任何人使用的都是与你是完全一致的依赖。 你的 CI 服务器,生产服务器,团队的其他开发人员,所有人都使用的是相同的依赖项,这减轻了仅部署某些部分而引起错误的可能性。即使你独立开发,在你重新安装项目的 6 个月内,你的依赖项发布了许多新的版本,你依然可以确信你的依赖项是可用的。(请参阅下边有关使用 update 的命令。)

更新依赖到最新版本

如上所述,composer.lock 文件将阻止你自动获取最新依赖版本。如果要更新依赖到最新版本,使用 update 命令。这将获取最新匹配的版本(根据你的 composer.json 文件)并将新版本更新到 composer.lock 文件。(这相当于删除 composer.lock 文件并再次运行 install)。

php composer.phar update

注意:当执行 install 命令时,由于 composer.json 的更改可能影响到依赖解析而未更新 composer.lock ,Composer 将显示警告。

如果只是想安装或更新一个依赖,可以将它们列出来:

php composer.phar update monolog/monolog [...]
注意:对于库来说,没必要提交 composer.lock 文件,请参考:库 - 锁文件。

Packagist

Packagist 是 Composer 的主要资源库。一个 Composer 库基本上是一个包的源:一个你可以得到包的地方。
Packagist 的目标是成为一个任何人都可以使用的中央仓库。这意味着你可以 require 那里的任何包,无需指定 Composer 查找包的位置。

当你访问 Packagist 网站 (packagist.org),你可以浏览和搜索包。

建议使用 Composer 的开源项目在 Packagist 上发布包。虽然并不一定需要发布在 Packagist 上来被 Composer 使用,但是它能被其它的开发者更快的发现和采用。

平台包

Composer 将那些已经安装在系统上,但并不是由 Composer 安装的包视为虚拟的平台包。这包括 PHP 本身、PHP 扩展和一些系统库。

php 代表使用的 PHP 版本要求,允许你应用限制,例如 ^7.1 。如果需要 64 位版本的 PHP, 你可以使用 php-64bit 进行限制。

hhvm 代表 HHVM 运行环境的版本,并且允许你应用限制 ,例如,^2.3。

ext- 允许你依赖 PHP 扩展(包括核心扩展)。通常 PHP 拓展的版本可以是不一致的,将它们的版本约束为 * 是一个不错的主意。一个 PHP 扩展包的例子是:ext-gd。

lib- 允许对 PHP 库的版本进行限制。以下可用例子: curl, iconv, icu,libxml,openssl, pcre, uuid, xsl。

你可以使用命令 show --platform 去获取你本地可用的平台包。

自动加载

为了描述包的自动加载信息, Composer 会生成一个 vendor/autoload.php 文件,你可以简单的 include 这个文件,并在无需其它额外工作的情况下就可以使用这些包所提供的类:

require __DIR__ . '/vendor/autoload.php';

$log = new Monolog\Logger('name');
$log->pushHandler(new Monolog\Handler\StreamHandler('app.log', Monolog\Logger::WARNING));
$log->addWarning('Foo');

你甚至可以在 composer.json 中添加一个 autoload 指令,来添加自己的自动加载声明

{
    "autoload": {
        "psr-4": {"Acme\\": "src/"}
    }
}

Composer 会为 Acme 命名空间注册一个 PSR-4 的自动加载.

你定义一个命名空间指向目录的映射。 在 vendor 目录同级的 src 目录将成为你项目的根目录。一个案例,文件名 src/Foo.php 需包含 AcmeFoo 类。

添加 autoload 指令之后,你必需重新运行 dump-autoload 来重新生成 vendor/autoload.php 文件。

包含此文件后也可以接收到一个 autoloader 实例,由因此您可以将 include 调用的返回值存储在变量中并添加更多名称空间,这在测试套件中将会很有用,例如:

$loader = require DIR . '/vendor/autoload.php';
$loader->addPsr4('Acme\Test\', __DIR__);
作为 PSR-4 自动加载规范的补充,Composer 也支持 PSR-0、类表、文件清单的自动加载方式。具体请查询 autoload 引用。

你也可以查阅 optimizing the autoloader 了解关于自动加载器的优化.

注意:Composer 提供自己的加载器,但如果你不想使用那个而想自己配置加载器的话,你可以试试 include vendor/composer/autoload_*.php 这些文件所返回的关联数组来实现。

网友评论

登录后评论
0/500
评论
ap5980n2w
+ 关注