Linux 安装python3.7.4

  1. 云栖社区>
  2. 博客>
  3. 正文

Linux 安装python3.7.4

检查人员 2019-08-04 09:37:08 浏览1451
展开阅读全文

我这里使用的分配的专用ECS,系统本身默认安装有python2.x,版本x根据不同版本有 所不同,可通过 python --V 或 python --version 查看系统自带的python版本,有一些系统命令时需要用到python2,不能卸载!

1、安装依赖包

1)首先安装gcc编译器,gcc有些系统版本已经默认安装,通过 gcc --version 查看,没安装的先安装gcc,yum -y install gcc

2)安装其它依赖包,(注:不要缺少,否则有可能安装python出错,python3.7.4以下的版本可不装 libffi-devel )

yum -y install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gdbm-devel db4-devel libpcap-devel xz-devel libffi-devel

2、下载python3.7.4源码,根据需求下载

1)在https://www.python.org/downloads/source/中选择自己需要的python源码包,我下载的是python3.7.4

2)下载:wget https://www.python.org/ftp/python/3.7.4/Python-3.7.4.tgz

3)解压Python-3.7.4.tgz

tar -zxvf Python-3.7.4.tgz

3、建立一个空文件夹,用于存放python3程序        

mkdir /usr/local/python3

4、执行配置文件,编译,编译安装            

cd Python-3.7.4
./configure --prefix=/usr/local/python3
make && make install
安装完成没有提示错误便安装成功了

5、建立软连接                     

ln -s /usr/local/python3/bin/python3.7 /usr/bin/python3
ln -s /usr/local/python3/bin/pip3.7 /usr/bin/pip3

6、测试一下python3是否可以用              

[root@ecs-rc3-large-4-linux-20190802155355 Python-3.7.4]# python3
Python 3.7.4 (default, Aug 3 2019, 09:21:23)
[GCC 4.8.5 20150623 (Red Hat 4.8.5-36)] on linux
Type "help", "copyright", "credits" or "license" for more information.

print ("hello huawei")
hello huawei
exit ()

[root@ecs-rc3-large-4-linux-20190802155355 Python-3.7.4]# pip3 --version
pip 19.0.3 from /usr/local/python3/lib/python3.7/site-packages/pip (python 3.7)
可以看到python3.7.4可以正常使用

网友评论

登录后评论
0/500
评论
检查人员
+ 关注