dpkg 被中断、sudo apt-get upgrade失败

  1. 云栖社区>
  2. 博客>
  3. 正文

dpkg 被中断、sudo apt-get upgrade失败

时光不写博客 2019-07-19 20:45:52 浏览305
展开阅读全文
  1. 写了个小插件,服务器部署的时候发现少了一些依赖,果断apt-get,然而失败了:

    E: dpkg 被中断,您必须手工运行 ‘sudo dpkg --configure -a’ 解决此问题。
  2. 找到解决办法:

    sudo rm /var/lib/dpkg/updates/*
    sudo apt-get update
    sudo apt-get upgrade
  3. 解决了么?并没有...。在sudo apt-get upgrade的时候失败了:

    您希望继续执行吗? [Y/n] y
    正在预设定软件包 ...
    /tmp/console-setup.config.XTxu0f: 1: eval: Syntax error: Unterminated quoted string
    预设定 console-setup 失败,退出状态为 2
    /tmp/keyboard-configuration.config.lBbgUO: 1: eval: Syntax error: Unterminated quoted string
    预设定 keyboard-configuration 失败,退出状态为 2
    正在设置 install-info (6.1.0.dfsg.1-5) ...
  4. 继续找解决办法:

    sudo mv /var/lib/dpkg/info /var/lib/dpkg/info_old   # 将info文件夹更名
    sudo mkdir /var/lib/dpkg/info  # 再新建一个新的info文件夹
    sudo apt-get update
    sudo apt-get -f install  # **这一句如果有问题请看第5步**
    sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info_old   # 执行完上一步操作后会在新的info文件夹下生成一些文件,现将这些文件全部移到info_old文件夹下
    sudo rm -rf /var/lib/dpkg/info  # 把自己新建的info文件夹删掉
    sudo mv /var/lib/dpkg/info_old /var/lib/dpkg/info   # 把以前的info文件夹重新改回名字
  5. sudo apt-get -f install的时候又碰到了一次E: dpkg 被中断,您必须手工运行 ‘sudo dpkg --configure -a’ 解决此问题。

    # 删除一下updates,重新来
    sudo rm /var/lib/dpkg/updates/*
    sudo apt-get -f install
  6. 终于弄完了,再来sudo apt-get upgrade,然鹅,有失败了:

    ...
    ...
    正在设置 keyboard-configuration (1.108ubuntu15.5) ...
    /var/lib/dpkg/info/keyboard-configuration.config: 1: eval: Syntax error: Unterminated quoted string
    dpkg: 处理软件包 keyboard-configuration (--configure)时出错:
     子进程 已安装 post-installation 脚本 返回错误状态 2
    dpkg: 依赖关系问题使得 console-setup-linux 的配置工作不能继续:
     console-setup-linux 依赖于 keyboard-configuration (= 1.108ubuntu15.5);然而:
      软件包 keyboard-configuration 尚未配置。
    ...
    ...
    dpkg: 依赖关系问题使得 ubuntu-minimal 的配置工作不能继续:
     ubuntu-minimal 依赖于 console-setup;然而:
      软件包 console-setup 尚未配�因为错误消息指示这是由于上一个问题导致的错误,没有写入 apport 报告。
                                                                                                      因为错误消息指示这是由于上一个问题导致的错误,没有写入 apport 报告。
                                      由于已经达到 MaxReports 限制,没有写入 apport 报告。
                                                                                          �。
    
    dpkg: 处理软件包 ubuntu-minimal (--configure)时出错:
     依赖关系问题 - 仍未被配置
    ...
    ...
    W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
    正在处理用于 libc-bin (2.23-0ubuntu11) 的触发器 ...
    在处理时有错误发生:
     keyboard-configuration
     console-setup-linux
     console-setup
     ubuntu-minimal
    E: Sub-process /usr/bin/dpkg returned an error code (1)
  7. 有点无奈,是我的操作有问题么?继续解决:

    再把第4步来一遍!!!
  8. 再来sudo apt-get upgrade

    终于搞定了
  9. 最后试一下:

    sudo apt-get install python-pip
    # 其实我就是为了安装一个pip

参考:
时光不写博客-dpkg 被中断、sudo apt-get upgrade失败
https://blog.csdn.net/zjwson/article/details/78239265
https://blog.csdn.net/ycl295644/article/details/44536297

网友评论

登录后评论
0/500
评论
时光不写博客
+ 关注