超大坑!springboot + vue + element-ui,运行前端项目报these dependencies were not found的问题

  1. 云栖社区>
  2. 博客>
  3. 正文

超大坑!springboot + vue + element-ui,运行前端项目报these dependencies were not found的问题

论尽先生 2019-03-17 22:06:37 浏览2204
展开阅读全文
These dependencies were not found:

* babel-runtime/core-js/json/stringify in ./src/mock/modules/sys-menu.js, ./src/
router/index.js and 1 other
* babel-runtime/core-js/object/keys in ./src/store/index.js
* babel-runtime/core-js/promise in ./src/utils/httpRequest.js
* babel-runtime/helpers/extends in ./src/router/index.js
* qs in ./src/utils/httpRequest.js
* svg-baker-runtime/browser-symbol in ./src/icons/svg/icon-tixing.svg, ./src/ico
ns/svg/icon-xiangqufill.svg and 29 others

To install them, you can run: npm install --save babel-runtime/core-js/json/stri
ngify babel-runtime/core-js/object/keys babel-runtime/core-js/promise babel-runt
ime/helpers/extends qs svg-baker-runtime/browser-symbol

解决办法:
1、安装cnpm(操作略了)
2、把该项目文件夹下的node_modules彻底删掉,必须彻底!
3、重新cmd-cnpm install-cnpm run dev ,ok! 解决!

答案我搜了很久,感谢其他站点给予提示的巨人们!

网友评论

登录后评论
0/500
评论
论尽先生
+ 关注