在Ubuntu搭建TensorFlow环境

  1. 云栖社区>
  2. 博客>
  3. 正文

在Ubuntu搭建TensorFlow环境

chszs 2018-01-06 11:29:54 浏览847
展开阅读全文
版权声明:本文为博主chszs的原创文章,未经博主允许不得转载。 https://blog.csdn.net/chszs/article/details/78987532

在Ubuntu搭建TensorFlow环境

  • 版权声明:本文为博主chszs的原创文章,未经博主允许不得转载。

我一直想要最大化TensorFlow的计算能力,于是我决定在家用电脑上安装和优化它。这里,我将分享如何选择安装TensorFlow的某个版本——它并不像看起来那么容易,因为你需要了解系统功能,而且涉及到GPU、以及你正在使用的Python版本。在选择TensorFlow的版本时,可以选择“Release”版本,也可以选择每日构建版。本文讲述如何轻松获得每日构建版并安装到自己的机器上运行。(系统环境是Ubuntu Linux)

在安装TensorFlow前,有四个主要选项:

  • Python 2.x
  • Python 2.x + GPU
  • Python 3.x
  • Python 3.x + GPU

带GPU支持的版本可以充分利用GPU的计算能力,但首先要检查您的系统是否支持CUDA GPU。

打开终端,执行命令:

# lspci | grep -i nvidia

看看返回了什么,比如我的:
检查是否支持CUDA GPU

查看GPU型号名称:GeForce GTX 860M,然后可以在NVIDIA官网检查是否兼容CUDA的信息,具体见:https://developer.nvidia.com/cuda-gpus

可以看到支持我的GPU,所以可以安装带GPU的TensorFlow版本。查看TensorFlow网站,具体见:https://www.tensorflow.org/install/install_linux

可以看到有一个我需要安装的依赖库libcupti。安装它:

# sudo apt-get install libcupti-dev

关于如何安装TensorFlow本身,可以阅读:https://www.tensorflow.org/install/install_linux#InstallingNativePip

使用Nightly Builds版安装TensorFlow

接下来需要确定本机的Python版本以及其相关的pip工具。如果还没有Python环境,应该先安装它们。可以参阅系统说明:https://www.python.org/

Ubuntu Linux默认自带了Python 2.7,就将就这个版本吧,先安装pip工具:

# sudo apt-get install python-pip python-dev

请注意,如果您使用Python 3.x,就应该使用软件包python3-pip和python3-dev。

还要注意,pip工具的版本至少应为8.1以上的版本。(用pip -V检查版本)

一旦完成了这一切,就可以简单地安装Nightly Build版的TensorFlow:

# sudo pip install tf-nightly-gpu

或者,如果您的系统不支持CUDA(请参阅上面的部分),请使用:

# sudo pip install tf-nightly

现在可以使用以下步骤检查TensorFlow是否工作。

首先:打开一个Python解释器:

# python

然后,导入TensorFlow库:

import tensorflow as tf

请注意,如果没有正确安装TensorFlow,或者将带GPU的版本安装在不受支持的系统上,就会在此处出现错误。CUDA错误在这一步上非常普遍。如果有效,就可以试试打印出TensorFlow的版本:

print(tf.__version__)

(注意version前后有2个下划线)

完成后,您应该看到打印出的TensorFlow版本 - 如下所示:
打印TensorFlow的版本

可以看到,由于使用了最新的每日构建版,所以TensorFlow当前的最新版本是1.4。

网友评论

登录后评论
0/500
评论
chszs
+ 关注