poj-1046-color me less

简介: Description A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform jus...

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation

Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set.

If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input

0 0 0
255 255 255
0 0 1
1 1 1
128 0 0
0 128 0
128 128 0
0 0 128
126 168 9
35 86 34
133 41 193
128 0 128
0 128 128
128 128 128
255 0 0
0 1 0
0 0 0
255 255 255
253 254 255
77 79 134
81 218 0
-1 -1 -1
题目大意:
前十六个数据代表已存入map的位置,根据公式求得数据到最近的已存在位置;

Sample Output

#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
struct mapa
{

int a;
int b;
int c;

};

int main()
{  mapa aa[16];
    for(int i=0;i<16;i++)
    {
        cin>>aa[i].a>>aa[i].b>>aa[i].c;

    }
     int x,y,z;
    while(cin>>x>>y>>z)
    {
        if(x==-1&&y==-1&&z==-1)break;
        int zh=255*255*3;
        int d,j=0;
        for(int i=0;i<16;i++)
        {
            d=sqrt((aa[i].a-x)*(aa[i].a-x)+(aa[i].b-y)*(aa[i].b-y)+(aa[i].c-z)*(aa[i].c-z));

            if(d<zh){zh=d;j=i;}


        }
        cout<<'('<<x<<','<<y<<','<<z<<')'<<" maps to "<<'('<<aa[j].a<<','<<aa[j].b<<','<<aa[j].c<<')'<<endl;

    }
system("pause");

    return 0;
}

  

(0,0,0) maps to (0,0,0)
(255,255,255) maps to (255,255,255)
(253,254,255) maps to (255,255,255)
(77,79,134) maps to (128,128,128)
(81,218,0) maps to (126,168,9)
相关文章
hdu 1312 Red and Black(BFS)
hdu 1312 Red and Black(BFS)
118 0
hdu 1312 Red and Black
一个人从@点出发,求他所能到达的'.'的数目,'#'不可走,@本身算1个点。 思路:搜索入门题。
122 0
HDOJ 1312 (POJ 1979) Red and Black
HDOJ 1312 (POJ 1979) Red and Black
90 0
|
机器学习/深度学习
HDOJ/HDU 1556 Color the ball(树状数组)
HDOJ/HDU 1556 Color the ball(树状数组)
82 0
ZOJ1067 Color Me Less
复制代码#include <iostream> #include <cmath> #include <limits> using namespace std; const int MAXSIZE = 100; int pos[100];//记录对应的最小值所在位置 struct RGB {//颜.
1432 0
|
Java 机器学习/深度学习
HDU 1556 Color the ball
Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 18404    Accepted Submission(s...
810 0