如何用conda安装软件|处理conda安装工具的动态库问题

  1. 云栖社区>
  2. 博客>
  3. 正文

如何用conda安装软件|处理conda安装工具的动态库问题

徐洲更 2018-04-18 08:53:00 浏览878
展开阅读全文
img_e76f5f10bdbdd280349d1024cad3e810.png
哪里不对修哪里

阅读完本文后,请看这一篇慎用Anaconda进行软件管理

conda的确是一个非常好的工具,对于初学者而言,安装软件就跟用XXX软件管理器一样方便。正因为他如此便利,以至于我介绍如何手动安装工具时,总有人问我为啥不用conda。

我用conda,并且用的很好。

下面解决一个非常有趣的conda安装工具后出现的动态库缺失的问题。这是我最近遇到的例子,

$ samtools
samtools: error while loading shared libraries: libtinfow.so.5: cannot open shared object file: No such file or directory

安装的samtools居然说不能用,原因是动态库找不到。那么这个问题应该怎么解决呢?

首先是确认问题,通过ldd查看samtools依赖了哪些工具。

$ which samtools
~/miniconda3/envs/align/bin/samtools
$ ldd ~/miniconda3/envs/align/bin/samtools
    linux-vdso.so.1 =>  (0x00007ffc4aef8000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f71902b3000)
    libz.so.1 => /home/wangjw/miniconda3/envs/align/bin/../lib/libz.so.1 (0x00007f719009b000)
    libm.so.6 => /lib64/libm.so.6 (0x00007f718fd99000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00007f718fb95000)
    libbz2.so.1.0 => /home/wangjw/miniconda3/envs/align/bin/../lib/libbz2.so.1.0 (0x00007f718f982000)
    liblzma.so.5 => /home/wangjw/miniconda3/envs/align/bin/../lib/liblzma.so.5 (0x00007f718f75c000)
    libdeflate.so => /home/wangjw/miniconda3/envs/align/bin/../lib/libdeflate.so (0x00007f718f551000)
    libncursesw.so.5 => /home/wangjw/miniconda3/envs/align/bin/../lib/libncursesw.so.5 (0x00007f718f2f6000)
    libcrypto.so.1.0.0 => /home/wangjw/miniconda3/envs/align/bin/../lib/libcrypto.so.1.0.0 (0x00007f718eeb6000)
    libcurl.so.4 => /home/wangjw/miniconda3/envs/align/bin/../lib/libcurl.so.4 (0x00007f718ec42000)
    libc.so.6 => /lib64/libc.so.6 (0x00007f718e87e000)
    /lib64/ld-linux-x86-64.so.2 (0x000055f87a5eb000)
    libtinfow.so.5 => not found
    librt.so.1 => /lib64/librt.so.1 (0x00007f718e675000)
    libssl.so.1.0.0 => /home/wangjw/miniconda3/envs/align/bin/../lib/./libssl.so.1.0.0 (0x00007f718e3ff000)

的确是libtinfow.so.5找不到了。

原因我根据直觉推测,是我安装的1.8版本的samtools的预编译版本安装时不会自带tinfow, 它默认我们自己提供tinfow这个动态库。

如何解决?

第一个方案降级samtools,没必要使用最新版的,新版虽然功能多,但是bug也不会少。所以可以使用旧版,比如说1.5

$ conda install samtools=1.5

ok,这个问题解决了

第二种方案,你一定要使用samtools的最新版,那么我们就自己解决不存在的依赖库问题。这个问题其实的确有人提及

img_8613b8f4a0df07156792a9292e4f810d.png
谷歌一下

有趣的是各个搜索引擎都企图让我把关键字改成libinfo.so.5,真的是有趣呀

img_b786ad8337e77d48dd68d35aed19afb4.png
ncurses不存在导致

当我准备去安装ncurses的时候,却提示这个软件已经安装好了。

$ conda install ncurses
# All requested packages already installed

但是问题还在这是为什么?显然是ncurses安装时存在了问题,当我卸载ncurses时我找到了问题所在,这就是conda的各个channel之间冲突了,默认去安装官方的ncurses,而不是

img_c734b64cf87b6b7996224e2acf39b8b1.png
注意ncurses的安装地址

因此修改~/.condarc提高conda-forge的优先级

img_30b30378ada95aba54dd7e0f48a72dcc.png
conda-forge优先级最高

再次安装:

img_a473827052d404fe5a0f03da034217cb.png
正确的地址

这下运行成功了

img_a8227a7a392e0b08b3113335801dcf4c.png
嘿嘿嘿

最后说明,samtools的tview依赖于ncurses。

网友评论

登录后评论
0/500
评论
徐洲更
+ 关注