maven eclipse 编译错误 Dynamic Web Module 3.0 requires Java 1.6 or new

  1. 云栖社区>
  2. 博客>
  3. 正文

maven eclipse 编译错误 Dynamic Web Module 3.0 requires Java 1.6 or new

curiousby 2016-11-03 15:40:00 浏览756
展开阅读全文

 

新建项目出现 Dynamic Web Module 3.0 requires Java 1.6 or new 



 

编译器的java版本不同导致


 

 

 

解决方法:pom添加 这段,eclpise 一下

 

<plugins>
			<plugin>
				<groupId>org.apache.maven.plugins</groupId>
				<artifactId>maven-compiler-plugin</artifactId>
				<version>3.3</version>
				<dependencies>
					<dependency>
						<groupId>org.codehaus.plexus</groupId>
						<artifactId>plexus-compiler-javac</artifactId>
						<version>2.5</version>
					</dependency>
				</dependencies>
				<configuration>
					<source>1.7</source>
					<target>1.7</target>
					<encoding>UTF-8</encoding>
					<compilerArguments>
						<verbose />
						<bootclasspath>${java.home}/lib/rt.jar:${java.home}/lib/jce.jar</bootclasspath>
					</compilerArguments>
				</configuration>
			</plugin>

 

 

 

 

 

 

 

 

 

 

捐助开发者

在兴趣的驱动下,写一个免费的东西,有欣喜,也还有汗水,希望你喜欢我的作品,同时也能支持一下。 当然,有钱捧个钱场(右上角的爱心标志,支持支付宝和PayPal捐助),没钱捧个人场,谢谢各位。



 
 
 谢谢您的赞助,我会做的更好!

 

 

 

 

网友评论

登录后评论
0/500
评论
curiousby
+ 关注