Hive Schema version 2.1.0 does not match metastore(版本不匹配)解决

  1. 云栖社区>
  2. 博客>
  3. 正文

Hive Schema version 2.1.0 does not match metastore(版本不匹配)解决

bymain 2018-04-10 20:13:14 浏览776
展开阅读全文

Caused by: MetaException(message:Hive Schema version 2.1.0 does not match metastore’s schema version 1.2.0 Metastore is not upgraded or corrupt)_2

解决方案:

1.登陆mysql,修改hive metastore版本:
进行mysql:mysql -uroot -p (123456)
use hive;
select * from version;
update VERSION set SCHEMA_VERSION='2.1.1' where  VER_ID=1;

2.简单粗暴:在hvie-site.xml中关闭版本验证

<property>
    <name>hive.metastore.schema.verification</name>
    <value>false</value>
</property>

网友评论

登录后评论
0/500
评论
bymain
+ 关注