(翻译)Gradle的安装

  1. 云栖社区>
  2. 博客>
  3. 正文

(翻译)Gradle的安装

davelet 2014-01-11 16:58:00 浏览415
展开阅读全文

原文地址 http://www.gradle.org/docs/current/userguide/installation.html

4.1. Prerequisites先决条件

Gradle依赖于JDK,需要已经安装好5.0(包括)以上的版本。虽然Gradle是基于Groovy配置的,但是不需要安装Groovy,它自带了。如果你已经安装了Groovy,没有关系,它会忽略掉的。

Gradle会在Path路径寻找JDK,找到哪个版本就用哪个版本。你自己可以用 java -version来检查你的Java版本。你也可以设置JAVA_HOME 环境变量指明已安装和期望使用的是哪个JDK。

4.2. Download下载

可以到这个地方下载Gradle的发行版:Gradle web site.

4.3. Unpacking解压

Gradle发行版是一个ZIP包。包括以下及部分:

  • 二进制文件

  • 用户手册,HTML和PDF的

  • DSL引用指南。

  • API文档,包括Javadoc和Groovydoc.

  • 丰富的例子,包括用户手册中的例子和其他完整的复杂的例子,你可以从简单的开始看。

  • 二进制源码。这只是用来引用的,如果你要自己构建Gradle需要去下载源码发行版。详情到这来看吧:Gradle web site.

4.4. Environment variables环境变量

要运行Gradle,需要让PATH变量包含 GRADLE_HOME/bin . 仅此而已吗,足够了。

4.5. Running and testing your installation测试安装

可以通过 gradle 命令行运行Gradle。要看Gradle是否正确安装了,用 gradle -v最简单了。输出是Gradle的版本还有其他一些环境配置信息。如果你看到的显示版本根本不是你自己下载的,哼哼,撞墙去吧。

4.6. JVM options JVM选项

你可以通过环境变量设置虚拟机选项,使用GRADLE_OPTS或者JAVA_OPTS就行,或者一起上吧。JAVA_OPTS一般的是给很用应用使用的。比如设置HTTP代理使用JAVA_OPTS,而设置内存选项使用GRADLE_OPTS。你可以在gradle 或 gradlew 脚本的开头设置这些变量。

 

网友评论

登录后评论
0/500
评论
davelet
+ 关注