关于对象数据库 DB4O 的一些BUG以及如何应对的方法

  1. 云栖社区>
  2. 博客>
  3. 正文

关于对象数据库 DB4O 的一些BUG以及如何应对的方法

阿敏总司令 2007-03-20 18:41:00 浏览616
展开阅读全文

关于对象数据库 DB4O 的一些BUG以及如何应对的方法

1、objectmanager 6.0不能正常显示中文而是框框,是字体设置不正确的原因,因为没有源程序,所以无法定位在哪里出了问题。

2、objectmanager 6.0需要对应db4o 6.1的版本

     objectmanager 1.8需要对应db4o 5.5的版本

     objectmanager 1.7需要对应db4o 5.2的版本

版本不对应会造成无法打开数据库文件,怎么就这么不兼容呢?连高版本的管理工具都无法打开旧的数据库。

3、com.db4o.eclipse_0.2.0默认只能打开db4o 5.2的版本的数据库

可以通过修改com.db4o.eclipse.plugin_0.2.0.jar包里的db4o的.jar文件,更换为不同的版本后来访问相应版本的数据库。

先解压 com.db4o.eclipse.plugin_0.2.0.jar 包,到 com.db4o.eclipse.plugin_0.2.0 目录下
方法一:
  把 db4o-5.5-java1.2.jar 或 db4o-6.1-java1.2.jar 等jar文件改名为 db4o-5.0-java1.2.jar ,然后拷贝过来覆盖掉原来的 db4o-5.0-java1.2.jar 文件,重新打开 Eclipse 即可。
方法二:
  拷贝 db4o-5.5-java1.2.jar 或 db4o-6.1-java1.2.jar 等jar文件 到com.db4o.eclipse.plugin_0.2.0 目录下,
  然后进入 com.db4o.eclipse.plugin_0.2.0/META-INF 目录下,打开 MANIFEST.MF 文件,将里面的 db4o-5.0-java1.2.jar 替换成拷贝进来的相应版本的jar文件名,保存,重新打开 Eclipse 即可。

两种方式其实就是替换不同版本的jar文件而已。

4、在用工具打开时有问题时,还需要进入当前用户的目录下将.objectmanager.*之类的文件删除后,再运行工具来打开数据库。
  比如: X:/Documents and Settings/YuLimin 目录下的 .objectmanager.yap之类的文件 

网友评论

登录后评论
0/500
评论
阿敏总司令
+ 关注