poj 1006 Biorhythms(中国剩余定理)

简介:
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 94863   Accepted: 29139

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

中国剩余定理:同余定理:
在《孙子算经》中有这样一个问题:“今有物不知其数,三三数之剩二(除以3余2),五五数之剩三(除以5余3),七七数之剩二(除以7余2),问物几何?”这个问题称为“孙子问题”,该问题的一般解法国际上称为“中国剩余定理”。具体解法分三步:
  1. 找出三个数:从3和5的公倍数中找出被7除余1的最小数15,从3和7的公倍数中找出被5除余1 的最小数21,最后从5和7的公倍数中找出除3余1的最小数70。
  2. 用15乘以2(2为最终结果除以7的余数),用21乘以3(3为最终结果除以5的余数),同理,用70乘以2(2为最终结果除以3的余数),然后把三个乘积相加(15*2+21*3+70*2)得到和233。
  3. 用233除以3,5,7三个数的最小公倍数105,得到余数23,即233%105=23。这个余数23就是符合条件的最小数。


即:对于n1,n2,n3三个数,某个数m对n1,n2,n3分别取模为a,b,c;

a = m%n1;

b = m%n2;

c = m%n3;

此时求m的值。

(1)求n1,n2的最小公倍数的倍数中模n3为1的数m3

(2)求n1,n3的最小公倍数的倍数中模n2为1的数m2

(2)求n1,n2的最小公倍数的倍数中模n1为1的数m1

m = (m1*a+m2*b+m3*c)%(n1*n2*n3)

复制代码
/**
    中国剩余定理:同余定理
    
*/
#include <stdio.h>
int main()
{
    int p,e,i,d,k=1,days;
    int num1,num2,num3;
    for(int j = 1; ; j++)
    if(28*33*j%23==1){num1 = 33*28*j;break;}
    for(int j = 1; ; j++)
    if(23*33*j%28==1){num2 = 23*33*j;break;}
    for(int j = 1; ; j++)
    if(23*28*j%33==1){num3 = 23*28*j;break;}
    while(scanf("%d%d%d%d",&p,&e,&i,&d)!=EOF)
    {
        if(p==-1&&e==-1&&i==-1&&d==-1)break;
        days = (p*num1+e*num2+i*num3-d)%(23*33*28);
        if(days<=0)days = 21252-d;
        printf("Case %d: the next triple peak occurs in %d days.\n",k++,days);
    }
    return 0;
}
复制代码








本文转自NewPanderKing51CTO博客,原文链接: http://www.cnblogs.com/newpanderking/archive/2012/09/27/2706419.html  ,如需转载请自行联系原作者





相关文章
|
3月前
|
算法 数据建模
Poj 3169(差分约束系统)
Poj 3169(差分约束系统)
20 0
|
8月前
|
容器
POJ 3640 Conformity
POJ 3640 Conformity
40 0
|
人工智能 机器学习/深度学习
|
人工智能 算法 BI
poj 2192 Zipper
题目链接:http://poj.org/problem?id=2192 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 18658   Accepted: 6651 Description Given ...
951 0
poj 2299 求逆序数
http://poj.org/problem?id=2299 #include using namespace std; int aa[500010],bb[500010]; long long s=0; void merge(int l,int m,int r) { ...
766 0
|
人工智能
POJ 1936 All in All
Description You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way.
756 0
|
机器学习/深度学习 算法
|
机器学习/深度学习 Windows