pomelo---- chat----初级搭建

  1. 云栖社区>
  2. 博客>
  3. 正文

pomelo---- chat----初级搭建

技术小胖子 2017-11-09 17:53:00 浏览636
展开阅读全文

一、安装pomelo

   前言:Pomelo是游戏服务器框架,本质上也是高实时、可扩展、多进程的应用框架。除了在提供的库部分有一部分游戏专用的库,其余部分框架完全可用于开发高实时的应用。而且与现在有的node.js高实时应用框架如derby、socketstream、meteor等比起来有更好的可伸缩性。

对于大多数开发者而言,node.js的入门应用都是一个基于socket.io开发的普通聊天室, 由于它是基于单进程的node.js开发的, 在可扩展性上打了一定折扣。

我们这次是以聊天室为主,而基于pomelo框架开发的聊天应用天生就是多进程的,可以非常容易地扩展服务器类型和数量。详情请参考本文档末尾参考资料

安装前环境:

master ip:192.168.10.123 

slave   ip:192.168.10.172

node 版本相同 v0.10.26

python 版本 2.7.3 

OS :Red Hat Enterprise Linux Server release 6.2 (Santiago)

service iptables stop

setenforce 0/disabled

绝对统一路径:/opt/

相同用户 useradd pomelo

需要安装  redis   yum  install redis -y


安装前准备:

根据需要安装相应版本的Python和node

[root@AY14041810545836988bZ opt]# python --version

Python 2.6.6

一、下载Python2.7.3,此版本是适合node-gpy 的

  1. #wget http://python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2  

2.  #tar -jxvf Python-2.7.3.tar.bz2  

3.  cd Python-2.7.3

4.  

#./configure  

#make all            

#make install  

#make clean  

#make distclean  

5  .检查Python 版本

#/usr/local/bin/python2.7 -V  

6.建立软连接,使系统默认的 python指向 python2.7

#mv /usr/bin/python /usr/bin/python2.6.6  

#ln -s /usr/local/bin/python2.7 /usr/bin/python  

7.重新检验Python 版本

python -v

python --version    显示 2.7.3

8.解决系统 Python 软链接指向 Python2.7 版本后,因为yum是不兼容 Python 2.7的,所以yum不能正常工作,我们需要指定 yum 的Python版本

vim  、/usr/bin/yum

将文件头部的
#!/usr/bin/python --默认2.6.6时候,yum中默认是#!/usr/bin/python


改成
#!/usr/bin/python2.6.6     现在是2.7.3,所以需要改为#!/usr/bin/python2.6.6

突然发现输入法图标不见了,然后打字没有候选框!iBus 崩了!再次进行搜索,又是版本问题抓狂 iBus也是不支持Python2.7的啊!

9.配置iBus

分别用 vi 打开下面两个文件,找到 exec python 那一行,把exec python 改为 exec python2.6 保存,退出。iBus在重启后就恢复正常了


1   .vim /usr/bin/ibus-setup

  1. #vi/usr/libexec/ibus-ui-gtk


[root@AY14041810545836988bZ opt]# node --version

v0.10.26

在安装此版本node时候,需要配置环境变量

/etc/profile

export NODE_HOME=/usr/local/node-v0.10.26-linux-x64

export PATH=$PATH:$NODE_HOME/bin

export NODE_PATH=$NODE_HOME/lib/node_modules

二、开始安装:

1、通过如下命令下载源代码的方式安装:

$ git clone https://github.com/NetEase/pomelo.git

cd pomelo

$ npm install -g

2、下载chat源码在github上面   -在此步骤期间,不要修改任何配置文件

$ git clone https://github.com/NetEase/chatofpomelo-websocket.git

$ cd chatofpomelo-websocket

$ cd game-server

$npm install

$ git checkout tutorial-starter

假如是分布式chat,执行以下步骤【】,如果不是分布式,则跳过~ 

详细请点击https://github.com/NetEase/pomelo/wiki/%E6%89%A9%E5%85%85%E6%9C%8D%E5%8A%A1%E5%99%A8

【多服务器版本的聊天应用在分支tutorial-multi-server上,你需要执行如下命令来切换到多服务器分支上:

$ git checkout tutorial-multi-server

假如需要安装后台模块,进行监控信息systeminfo,则需要打开admin model【】,不需要,请跳过

【$ git checkout tutorial-admin-module】

首先,确保你已经成功安装了pomelo。执行命令安装依赖:

$ sh npm-install.sh

启动游戏服务器:

$ cd game-server

$ pomelo start

启动web服务器:

$ npm install

$ cd web-server$ node app.js

如果启动过程中没有问题的话,下面我们就可以使用我们的聊天服务了,打开浏览器

http://127.0.0.1:3001/  即可、


      本文转自crazy_charles 51CTO博客,原文链接:http://blog.51cto.com/douya/1408813,如需转载请自行联系原作者


网友评论

登录后评论
0/500
评论
技术小胖子
+ 关注