14.二层技术之VLAN与Trunk中继(DTP协议)

  1. 云栖社区>
  2. 博客>
  3. 正文

14.二层技术之VLAN与Trunk中继(DTP协议)

技术小牛人 2017-11-21 23:04:00 浏览1041
展开阅读全文

VLAN叫虚拟局域网,VLAN的作用是将控制广播,处于同一VLAN中的设备可以相互通信,不同VLAN中的设备如果需要通信需要借助三层设备做转发。

VLAN的优势:控制广播,增强网络安全性,简化网络管理。

DTP叫动态中继协议,两个交换机接口间通信接口必须为Trunk且封装模式必须相同。

交换机接口协商模式:

Access接入模式:非中继链路,用于PC接入。

Trunk中继模式:中继链路,可以协商,主发,被动响应。

Dynamic desirable期望模式:必须协商,主发,被动响应

Dynamic auto自动模式:必须协商,不主发,被动响应。

Nonegotiate非协商模式:不协商。

封装模式:

ISL交换机间链路:思科的私有标记方法,只支持1024VLAN

802.1Q:公有的标记方法,支持4096VLAN

VTP虚拟局域网中继协议:VLAN同步技术,思科的私有协议,只可以在思科设备上使用。

VTP同步的条件:相同的VTP域名,必须是Trunk链路。

VTP有三种工作模式:服务模式可创建修改同步VLAN,客户模式不可创建修改但同步VLAN,透明模式可创建修改但不同步VLAN

VTP修剪技术是VLAN的优化技术,通过VTP同步的,可以提高网络带宽。

CISCO思科交换机命令

命令

描述

# vlan database

进入VLAN配置

(vlan)# vlan 10 name a

创建VLAN并命名

(vlan)# vtp domain a(域名)

配置VTP域名

(vlan)# vtp mode serverclienttransparent

配置VTP工作模式

(vlan)# vtp pruning

配置VTP修剪

(vlan)# exit

保存并退出VLAN配置

# show vlan

查看VLAN列表

# show interface f0/0 swichport

查看该接口的二层信息

# show vtp status

查看VTP信息

# show interface trunk

查看Trunk信息

(config)# interface range f0/0 -4(多个接口)

同时进入多个接口

(config-if)# switchport trunk encapsulation dot1q

配置接口封装模式为802.1Q

(config-if)# switchport mode accessTrunk

配置接口模式

(config-if)# switchport access vlan 10

将接口划入VLAN10

(config-if)# switchport native vlan 10

设置默认VLANVLAN10

(config-if)# switchport trunk allowed vlan remove vlan 10

Trunk中删除VLAN10,意思就是不允许VLAN10通过

(config-if)# switchport trunk allowed vlan add vlan 10

Trunk中添加VLAN10,意思就是允许VLAN10通过

华为的接口模式:

Access模式:接入模式,用于PC接入。

Trunk模式:中继模式,用于多台交换机间通信。

Hybrid模式:混合模式,可以将一个接口加入到多个VLAN中。

VLANIF接口:逻辑虚拟接口,相当于思科设备的VLAN虚接口。

华为交换机命令

命令

描述

[huawei] vlan 10

创建VLAN

[huawei] vlan batch 10 20 30

同时创建多个VLAN

[huawei-vlan] quit

保存并退出VLAN配置

[huawei] display vlan

查看VLAN列表

[huawei] display interface e0/0/1

查看该接口的二层信息

[huawei] interface ethernet0/0/0 to 0/0/9

同时进入多个接口

[huawei-Ethernet0/0/0] port link-type acccess

配置接口为Access模式

[huawei-Ethernet0/0/0] port accesst vlan 10

将接口划入VLAN10

[huawei-Ethernet0/0/0] port link-type trunk

配置接口为Trunk模式

[huawei-Ethernet0/0/0] port trunk allow-pass vlan 10

允许VLAN10通过

[huawei-Ethernet0/0/0] port link-type hybrid

配置接口为hybrid混合模式

[huawei-Ethernet0/0/0] port port hybrid untagged vlan 10 20 30

将该接口加入到多个VLAN 

注:思科默认允许所有VLAN通过Trunk,而华为H3C需要手动配置。

本文转自   触动的风   51CTO博客,原文链接:http://blog.51cto.com/10978134/1904043

网友评论

登录后评论
0/500
评论
技术小牛人
+ 关注