cisco课程3

  1. 云栖社区>
  2. 博客>
  3. 正文

cisco课程3

技术小胖子 2017-11-08 15:03:00 浏览796
展开阅读全文

网关冗余协议:
HSRP - 思科私有协议
VRRP - 公有标准
(将HSRP的配置命令中的standby,更改为vrrp,就可以)

HSRP:hot standby routing protocol - 热备份路由协议
-作用
在同一个网段的多个网关之间运行该协议,
可以形成一个虚拟的网关(虚拟网关IP和虚拟网关MAC)
该网段的终端在配置网卡时,网关IP地址都设置为
该虚拟网关IP地址;
多个真实的网关设备为虚拟IP而服务;
从而可以实现网关的冗余性和网络的稳定性。
同时,还可以实现数据的负载均衡。
-角色
多个真实设备虚拟出来的“虚拟网关”,有角色之分:
主设备 - active ; 
备设备 - standby ; 
选择原则:
1、参与网关虚拟化的设备,首先比较
优先级 ,越大越好;默认值为100;
2、如果优先级相同,则比较IP地址,
越大越好 ;
-注意: 
HSRP 是思科私有协议,其他厂商的设备不支持
HSRP 发送 hello 的周期性时间为 3s 
HSRP 的保持时间 - hold ,为 10s 
HSRP 默认没有开启“抢占”功能,对于主设备,
必须开启;
HSRP 支持外部链路跟踪技术;

HSRP 配置思路:
前提:
必须达成共识 - 
网关是一个设备的“接口”概念;所以HSRP的相关
配置必须是在“网关接口”下配置的;

1、在网关(端口)上启用 HSRP,并配置虚拟网关IP地址
     GW1/2:
        interface gi0/0 
           standby 10 ip  192.168.10.250    
2、在主网关(端口)上,调整 HSRP的优先级。越大越好;
      GW1:   // 将 GW1 配置为主网关;
        interface gi0/0 
            standby 10 priority 105             
3、在网关(端口)上开启 HSRP 的抢占功能
       GW1:
         interface  gi0/0 
             standby  10  preempt   
4、配置终端设备的网关IP为“虚拟网关的IP地址”;
   PC1 192.168.10.1     PC2  192.168.10.2
       255.255.255.0         255.255.255.0 
       192.168.10.250        192.168.10.250 
5、验证与测试
      show standby - > 查看 HSRP 的相关信息;
      debug ip icmp --> 查看 ICMP 的报文处理信息

HSRP 外部链路跟踪:
当网关的外部链路断开以后,HSRP 会自动的降低
自己的优先级。降低的优先级幅度,是可以人工
配置的;(模拟器上,不能配置,只能降低固定的10)

配置命令:
    interface gi0/0
       standby 10 track interface gi0/1 [X]

        注意:
           参数 X 是在真实设备上才会有的;
           表示的是人工指定的降低的优先级幅度;

HSRP的负载均衡
-背景 
当主网关与备网关都OK的时候,备网关实现的作用
仅仅是备份,即设备的利用率仅仅有 50%,所以
存在设备浪费/设备利用率不高的问题。
所以, HSRP 开始支持 流量“负载均衡”功能,
即,当主网关与备网关都 OK 的时候,
会同时通过两个网关进行流量的转发,从而就
提高了网关设备的利用率;
如果主网关挂掉,之前经过主网关转发的流量
就会经过备网关转发,依然实现了“网关备份”
的功能。
-方式:
HSRP group ,即 HSRP 组;

-配置:
   0、前提:使用“多层交换机”作为“网关设备”;

   1、将SW1作为 VLAN1-2 的主网关设备,优先级设为105
      并为这些 VLAN的网关,开启 HSRP 抢占功能    

interface Vlan1
ip address 192.168.1.1 255.255.255.0
standby 1 ip 192.168.1.250
standby 1 priority 105
standby 1 preempt
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
standby 2 ip 192.168.2.250
standby 2 priority 105
standby 2 preempt
!
interface Vlan3
ip address 192.168.3.1 255.255.255.0
standby 3 ip 192.168.3.250
!
interface Vlan4
ip address 192.168.4.1 255.255.255.0
standby 4 ip 192.168.4.250

   2、将SW2作为 VLAN3-4 的主网关设备,优先级设为105
      并为这些 VLAN的网关,开启 HSRP 抢占功能    

interface Vlan1
ip address 192.168.1.2 255.255.255.0
standby 1 ip 192.168.1.250
!
interface Vlan2
ip address 192.168.2.2 255.255.255.0
standby 2 ip 192.168.2.250
!
interface Vlan3
ip address 192.168.3.2 255.255.255.0
standby 3 ip 192.168.3.250
standby 3 priority 105
standby 3 preempt
!
interface Vlan4
ip address 192.168.4.2 255.255.255.0
standby 4 ip 192.168.4.250
standby 4 priority 105
standby 4 preempt

,如需转载请自行联系原作者

网友评论

登录后评论
0/500
评论
技术小胖子
+ 关注