使用隧道技术打造帧中继网络

  1. 云栖社区>
  2. 博客>
  3. 正文

使用隧道技术打造帧中继网络

余二五 2017-11-21 00:03:00 浏览845
展开阅读全文
今天是周末,有大块的时间来做做实验,感觉不错!
今天做的实验是使用思科路由器结合隧道技术打造帧中继网络,做完这个实验,帧中继对于你我不再是雾里看花了~
一.实验拓扑图:
1、云团未被揭开的实验拓扑:
目标拓扑
2、透过云团看到的实验拓扑:
实验拓扑
二.配置详情:
1.路由器R1的完整配置:
Router#conf t
Router(config)#hostname R1
R1(config)#INT LOOpback 0 
R1(config-if)#IP ADD 1.1.1.1 255.255.255.0 
R1(config-if)#no shutdown 
R1(config-if)#int f1/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown 
R1(config-if)#exit
R1(config)#router rip 
R1(config-router)#ver 2
R1(config-router)#no auto-summary 
R1(config-router)#network 10.0.0.0
R1(config-router)#end
R1#conf t
R1(config)#frame-relay switching 
R1(config)#ip host R3 3.3.3.3
R1(config)#int tunnel 0 
R1(config-if)#tunnel source LOopback 0
R1(config-if)#TUnnel DEStination R3
R1(config)#int s0/0
R1(config-if)#encapsulation frame-relay ietf 
R1(config-if)#frame-relay intf-type dce
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#end
R1#conf t
R1(config)#int s0/0
R1(config-if)#frame-relay route 101 interface tunnel 0 200 
2.路由器R2的完整配置:
Router#conf t
R2(config)#int f0/0 
R2(config-if)#ip add 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown 
R2(config-if)#int f1/0
R2(config-if)#ip add 10.1.2.1 255.255.255.0
R2(config-if)#no shutdown 
R2(config-if)#end
R2#conf t
R2(config)#router rip 
R2(config-router)#ver 2
R2(config-router)#no auto-summary 
R2(config-router)#network 10.0.0.0
R2(config-router)#end
3.路由器R3的完整配置:
Router>EN
Router#CONF T
Router(config)#HOStname R3
R3(config)#int loo 0
R3(config-if)#ip add 3.3.3.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3#conf t
R3(config)#int f0/0
R3(config-if)#ip add 10.1.2.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#end
R3#conf t
R3(config)#router rip
R3(config-router)#ver 2
R3(config-router)#no auto-summary 
R3(config-router)#network 3.0.0.0
R3(config-router)#network 10.0.0.0
R3(config-router)#end
R3#CONF T
R3(config)#IP HOSt R1 1.1.1.1
R3(config)#FRAme-relay SWItching 
R3(config)#int tunnel 0
R3(config-if)#tunnel source LOopback 0
R3(config-if)#tunnel destination R1
R3(config-if)#exit
R3(config)#int s1/0
R3(config-if)#encapsulation frame-relay ietf 
R3(config-if)#frame-relay intf-type dce
R3(config-if)#clock rate 64000
R3(config-if)#no shutdown 
R3(config-if)#end
R3#conf t
R3(config)#int s1/0
R3(config-if)#frame-relay route 201 interface tunnel 0 200 
R3(config-if)#end
4.路由器R4的完整配置:
Router>EN
Router#CONF T
Router(config)#HOStname R4
R4(config)#int s0/0
R4(config-if)#encapsulation frame-relay ietf
R4(config-if)#ip add 192.168.1.1 255.255.255.0
R4(config-if)#no shutdown 
R4(config-if)#end
5.路由器R5的完整配置:
Router>EN
Router#CONF T
Router(config)#HOStname R5
R5(config-if)#encapsulation frame-relay ietf 
R5(config-if)#ip add 192.168.1.2 255.255.255.0
R5(config-if)#no shutdown
以上就是这个实验的详细过程,大家可以参考着做一下~
三.验证
1.路由器R4和路由器R5互ping一下:
R4#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 288/350/432 ms
R5#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 312/380/460 ms
2.在路由器R4上运行show frame-relay pvc查看虚链路激活状况(能ping通自然没问题~)
pvcR4
3.在路由器R1、R3上查看帧中继路由状况,命令show frame-relay route:
frouteR1
frouteR3
实验做完了,对帧中继的疑团有没有消除呢?周末愉快,诸位兄弟!
如果觉得这个实验有意思,不妨动动手做一下~




本文转自 tiger506 51CTO博客,原文链接:http://blog.51cto.com/tiger506/116182,如需转载请自行联系原作者

网友评论

登录后评论
0/500
评论
余二五
+ 关注