Lync 2010迁移Lync 2013 PART5:支持旧版Lync

  1. 云栖社区>
  2. 博客>
  3. 正文

Lync 2010迁移Lync 2013 PART5:支持旧版Lync

技术小胖子 2017-11-09 23:41:00 浏览578
展开阅读全文
最近又忙了一小段时间,这么久没有写东西真不好意思,不知不觉博客的访问量也有15W了,其实我真的很感谢这么多兄弟、朋友对我的支持。因为大家的支持,我发现交流、分享是这么有意义的一件事,而51cto博客平台给我的感受不仅仅是分享,更多的是去相互学习,成长。所以我的成长和广大博友、51cto是分不开的,也不知道为什么突然会在这么晚说这么些话,可能在这里技术和知识真的得到了升华吧。
老规矩,下面开始正题吧。今天的内容并不多,也非常的简单,就是让我们Lync 2010客户端登录到我们的Lync Server 2013服务器。因为在我们部署Lync Server 2013并将用户迁移到Lync Server 2013池之后,我们再去使用Lync 2010客户端是没办法登录的,因为Lync默认是不允许低版本客户端登录高版本服务器的,这应该是出于功能上的考虑。
但可能很多朋友觉得Lync 2013不好用,或者说更习惯使用Lync 2010等等情况,所以我们必须要让Lync Server 2013服务器支持旧版本的客户端登录。下面一张图是通过Lync 2010客户端登录Lync Server 2013服务器时的错误,这个跟用OC客户端登录Lync 2010服务器是一样的效果。
clip_image001
这个问题仅仅是Lync Server 2013默认策略导致,我们在装有Lync Server 2013管理工具的机器上打开 Lync控制面板,或者在任意内部位置通过https://admin.domain.cn来访问Lync控制面板。如果是通过管理工具打开会让我们URL,我们选择Lync Server 2013的控制面板即可。
clip_image002
然后需要输入凭据。
clip_image003
打开控制面板后选择“客户端”选项卡。
clip_image004
在全局上单击编辑并选择显示详细信息。
clip_image005
这时我们先来看看Lync 2010客户端的版本,一般来说都是这版本4.0.7577.0。
clip_image006
我们在客户端版本中找到OC 版本为4.0.7577后面的小版本不用去管,直接双击编辑。
clip_image007
到这里面就会很详细了,其中4.0是主次版本,7577时内部版本,而最后的0是更新。所以我们要允许Lync 2010登录很简单,我们允许等于或高于4.0.7577.0的客户端登录即可。我们在下方修改比较操作“较新或相同”然后将操作设置为允许即可。
clip_image008
完成修改后提交我们的修改。
clip_image009
到这里就OK了,说到版本我们再来看个很有趣的东西。就是Lync 2013客户端的版本,没错是15.0.4420,什么意思呢?主要版本为15,较Lync 2010有11个版本的提升,那么这11个版本哪去了呢???
clip_image010
其实我们再认真想想,其实很简单了,因为Lync 2010、Office Communicator 2007 R2等等都是独立的安装程序也就是独立的客户端,而Lync 2013却是集成到了Office 2013也就是Office 15中,算是Office的组件,而Office 2013的版本正是15,所以Lync 2013的版本也就是15了。虽然从Lync 2010的4.0到15.0这个跳跃确实比较雷人,但也可以理解,毕竟现在Lync越来越重要了,不再像以前那样的仅仅是一个企业即时消息服务了,而是Office中的一部分。
到最后我们再来试试看客户端,OK,Lync 2010成功登录,没有问题。
clip_image011
今天的内容非常简单,也是我们Lync 2013系列一步一步走可能会遇到的问题,也许很多做Lync的兄弟会觉得很简单,但只要能够帮到来看我博客的任何一位兄弟、朋友,哪怕只有一点点帮助,这篇文章的字和图就值了。还是那句话,大家有什么问题或意见,回复文章,我会即时的回复,与大家一起交流、学习,谢谢大家!


 本文转自 reinxu 51CTO博客,原文链接:http://blog.51cto.com/reinember/1063281,如需转载请自行联系原作者


网友评论

登录后评论
0/500
评论
技术小胖子
+ 关注