eclipse3.2.1及插件安装基础教程

  1. 云栖社区>
  2. 博客>
  3. 正文

eclipse3.2.1及插件安装基础教程

最美的回忆 2017-11-29 22:12:00 浏览725
展开阅读全文

eclipse3.2.1及插件安装基础教程

 

1 下载:

Eclipse 的官方网站(www.eclipse.org)下载3.2.1Eclipse,压缩包名为eclipse-SDK-3.2.1-win32.zip,我下载后解压到D:"eclipse

 

2 语言包(安装后可中文化eclipse)下载及安装:

     下载地址:http://download.eclipse.org/eclipse/downloads/

打开下载地址,在页面最下端可看到下载3.2.1_Language_Packs

     D:"eclipse下新建文件夹,命名为”language”文件名可随意),解压下载的语言包到language目录下

     D:"eclipse 下新建文件夹,命名为 “links(名称不可随意),新建一文本文件language.link.txt.link文件的文件名和扩展名.txt可随意,内容为:path=language(也可使用绝对路径path=D:""eclipse""language或者path=D:/eclipse/language)。

     此时目录结构如下

D:"eclipse         //eclipse.exe所在目录

D:"eclipse"links

D:"eclipse"language"eclipse"features

D:"eclipse"language"eclipse"plugins

     启动eclipse,这时默认启动为中文界面,如果想启动英文eclipse,只要新建一eclipse.exe快捷方式,快捷方式属性”==>“目标中输入D:"eclipse"eclipse.exe -nl "en_US" 即可(中文界面可以设置-nl "zh_CN",繁体中文为-nl "zh_TW"

 

3 安装tomcatPlugin(安装后可在eclipse中直接使用tomcat)插件

     下载地址:http://www.sysdeo.com/eclipse/tomcatplugin

可以下载新的3.2 beta2版本,它支持eclipse3.2.1tomcat6.0

     D:"eclipse下新建文件夹,命名为myplugins(名称可随意),在”myplugins”下依次新建文件夹tomcat ”eclipse” ”plugins ”features ”,目录结构如下:

D:"eclipse"myplugins"tomcat"eclipse"features

D:"eclipse"myplugins"tomcat"eclipse"plugins

把解压后的tomcatPlugin文件夹放在此plugins目录下

     D:"eclipse"links 下新建一文本文件tomcat.link.txt.link文件的文件名和扩展名.txt可随意,内容为:path=myplugins/tomcat(也可使用绝对路径path=D:""eclipse""myplugins""tomcat)。

     启动eclipse,可在菜单栏看到”Tomcat”选项,此时还需对其进行配置,在”Window” ==>”Preferences”==>”Tomcat”中,选择Tomcat版本Version5.x(我使用的是Tomcat5.5.20,放在D:"Tomcat下,对于Tomcat6.0,可选择Version6.x),并设置Tomcat home;在”Context declaration mode”下有两种选择,一种是configuration file,默认放在D:"Tomcat"conf"server.xm中,一种是Context directory默认放在D:"Tomcat"conf"Catalina"localhost下,可根据需要自由选择(对于Tomcat6.0Context directory默认放在D:"Tomcat"webapps),在这里我选择”Context directory”,并更改为D:"Tomcat"webapps(这里选择哪一种无所谓,因为只是讨论tomcatPlugin的使用~~

     Tomcat菜单下启动tomcat即可

注意:对于eclipse3.2.1+tomcatPlugin3.2beta2,在Tomcat5.5.20Tomcat6.0下,都可以在eclipse中正常启动tomcat

对于Tomcat5.0.12,在eclipse中启动时Console会报错:

<terminated>Tomcat6.x[Java Application]C:"Java"jdk1.5.0"javaw.exe

很奇怪,报的是Tomcat6.x的错,可能是因为beta版的缘故吧,所以大家最好在apache网站上下载Tomcat5.5以上的版本(顺便说一句,Tomcat6.0支持最新的JSP2.1Servlet2.5,在后面做了点比较,以供参考)~~

     上面5步是一种比较麻烦的安装,呵呵~最简单的办法,是把解压后的tomcatPlugin文件夹直接放到D:"eclipse"plugins目录下,启动eclipse即可,不过这样安装会导致plugins目录越来越大,以后维护起来也不方便,所以最好采用上面的link方式安装~

 

4 Jadclipse插件(反编译工具)安装

     下载jad1.5.8g

下载地址:http://www.kpdus.com/jad.html#download

下载后解压。解压缩后将jad.exe拷贝到JDKbin目录下(放置位置可随意),如C:"Java"jdk1.5.0"bin

jad.exejava的反编译工具,一些经常使用的反编译工具如DJ Java DecompilerCavaj Java Decompiler等反编译引擎都是jad.exe,不过是在jad.exe上加了图形化界面而已

     下载jadclipse(一个在eclipse中调用jad.exe进行反编译的插件)

下载地址:http://jadclipse.sourceforge.net/ (下载包名为net.sf.jadclipse_3.2.3.jar

     tomcatPlugin一样,安装jadclipse插件有两种方法,一种是直接把jar包放到D:"eclipse"plugins目录下,另一种是采用link方式安装

     采用link方式安装时需要”myplugins”下依次新建文件夹jadclipse ”eclipse” ”plugins ” ”features ”,此时目录结构如下图:

把压缩包net.sf.jadclipse_3.2.3.jar放在jadclipse"eclipse"plugins目录下

     D:"eclipse"links 下新建一文本文件jadclipse.link.txt.link文件的文件名和扩展名.txt可随意,内容为:path=myplugins/jadclipse(也可使用绝对路径path=D:""eclipse""myplugins"" jadclipse

     启动eclipse,在”Window” ==>”Preferences”==>”Java”中可在看到多处一个”JadClipse”选项,设置path to decompilerjad.exe的全路径(否则会出错java.io.IOException: CreateProcess: jad -p -t4 -lnc -lradix10 -radix10,如:C:"Java"jdk1.5.0"bin"jad.exe(放在此JDK路径下也可直接在path to decompiler设为”jad”相对路径),在Directory for temporary files中指定临时文件的路径,如:C:"Documents and Settings"user".net.sf.jadclipse

     此时打开任意*.class文件,可看到反编译后的源文件

     注意:当新建一工程后,在eclipse中以debug模式运行tomcat时,当运行至*.jar包反编译时常会出现”Source not found”的问题,必须在Run”==>"Debug" ==>"Source" ==>"Add" ==>"Archive"加入反编译需要调用的jar包(工程中用到的jar包一般为$PROJECT_HOME/WEB-INF/lib下的jar包),这样进入时才会由jad反编译

 

5 myeclipse插件(插件集成包,集成了AppServer/JSP/JSF/Spring/Hibernate/XML/EJB

插件)安装

下载地址:http://www.myeclipseide.com/ContentExpress-display-ceid-10.html

呵呵,需要注册一个帐号才可以下载,而且myeclipse是收费的,不过网上注册码很多,顺便提供两个,有需要注册机的朋友可以联系我~~

License Name : eclipse

License Key : rLR8ZC-444-55-44678656900291869

License Name : myeclipse

License Key : zLR8ZC-444-55-4467865944410637

下载后一路next,我安装到D:"MyEclipse 5.0GA,可以看到MyEclipse目录结构如下:

D:"MyEclipse 5.0GA"eclipse"features

D:"MyEclipse 5.0G"eclipse"plugins

注意:因为myeclipse自带了语言包,所以上面建的language文件夹会被覆盖~~

安装后可在D:"eclipse"links下看到多出一个com.genuitec.eclipse.MyEclipse.link文件,其内容为:path=D:""MyEclipse 5.0GA

呵呵,和上面我们自定义的myplugins文件夹对比一下,它也是使用link方式安装插件的。

启动eclipse即可看到”Window” ==>”Preferences”下多了MyEclipse选项。

我们完全可以把D:""MyEclipse 5.0GA整个目录copyD:"eclipse下,修改com.genuitec.eclipse.MyEclipse.link为:

path=D:""eclipse""MyEclipse 5.0GA

 

6.   eclipse中只有CVS,对于vss,需要安装插件,

vssplugin下载地址为:http://sourceforge.net/projects/vssplugin/

VSS Plugin 1.6.1 的版本虽然标注支持Support for Eclipse 3.1 RCx ,不过在eclipse3.2.1可以正常使用~~

 

7.   另外还有一些比较不错的类似myeclipse的插件集成包(免费且均已支持eclipse3.2.1EasyEclipse/WTP自带eclipse,无需另外安装),比如

Exadel Studio 4.0.2 下载地址:http://www.exadel.com/web/portal/download/es

EasyEclipse Server Java1.2.1

下载地址:http://www.easyeclipse.org/site/distributions/server-java.html

WTP R-1.5.2WebTools Platform下载地址:http://www.eclipse.org/webtools/

个人感觉myeclipse占用内存比较大,EasyEclipse在中文支持上不是很好,WTP在代码匹配颜色上不突出,使用上还是Exadel Studio方便一些~

 

Tomcat6.0Tomcat5.5.20一些包的比较

Tomcat6.0

Tomcat5.5.20

* el-api.jar (EL 2.1 API)

* jasper.jar (Jasper 2 Compiler and Runtime)

* jasper-el.jar (Jasper 2 ELimplementation)

* jasper-jdt.jar (EclipseJDT 3.2 Java compiler)

* jsp-api.jar (JSP 2.1 API)

* servlet-api.jar (Servlet 2.5 API)

 

* jasper-compiler.jar (Jasper 2 Compiler)

* jasper-runtime.jar (Jasper 2 Runtime)

 

 

* jasper-compiler-jdt.jar (Eclipse JDTJava compiler)

* jsp-api.jar (JSP 2.0 API)

* servlet-api.jar (Servlet 2.4 API)

tomcat6.0中,有了一些新特性,且lib包直接置于$TOMCAT_HOME/lib下,不再有common/share/server三个包,并且JSP2.1EL包现在独立开来单独成为一个包

 本文转自kenty博客园博客,原文链接http://www.cnblogs.com/kentyshang/archive/2007/12/05/983225.html如需转载请自行联系原作者


kenty

网友评论

登录后评论
0/500
评论
最美的回忆
+ 关注