Dp_F Pku1157

简介:
<span style="color:#000099;">/*
F - 简单dp
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit
 
Status
Description
You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 
 	
V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7	23	-5	-24	16
2 (begonias)

5	21	-4	10	23
3 (carnations)

-21

5	-4	-20	20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 
Input
The first line contains two numbers: F, V.
The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
F <= V <= 100 where V is the number of vases. 
-50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.
Output
The first line will contain the sum of aesthetic values for your arrangement.
Sample Input
3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20
Sample Output
53
BY Grant Yuan 
2014.7.16
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int a[201][201];
int dp[201][201];
int m,n;
int max(int aa,int bb)
{
    return aa>=bb?aa:bb;
}
int main()
{
    while(~scanf("%d%d",&m,&n)){
      for(int i=0;i<m;i++)
        for(int j=0;j<n;j++)
          scanf("%d",&a[i][j]),dp[i+1][j+1]=a[i][j]
        for(int i=0;i<=m;i++)
        for(int j=0;j<=n;j++)
            dp[i][j]=-99999999;
        for(int i=0;i<n;i++)
             dp[0][i]=0;
        for(int i=0;i<m;i++){
        for(int j=i;j<n-m+1+i;j++)
          { 
            dp[i+1][j+1]=max(dp[i][j]+a[i][j],dp[i+1][j]);
            
           }}
           printf("%d\n",dp[m][n]);}
        return 0;

}
</span>

版权声明:本文博客原创文章。博客,未经同意,不得转载。





本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4636376.html,如需转载请自行联系原作者


相关文章
|
8月前
|
机器学习/深度学习 人工智能
|
7月前
|
决策智能
【dp】背包问题
【dp】背包问题
323 2
|
9月前
|
机器学习/深度学习
Dp练习
Dp练习
60 0
|
6月前
|
C++
9.DP单调队列优化
先弄出朴素DP->在用单调队列优化 一般都是区间的最大最小值,而且滑动的,才用单调队列优化
30 0
|
11月前
|
存储
动态规划(DP)
动态规划(DP)
35 0
|
11月前
|
存储 算法
dp 就 dp ,数位dp是什么意思 ?
dp 就 dp ,数位dp是什么意思 ?
227 0
|
算法
【动态规划】使用到dp的题
【动态规划】使用到dp的题
84 0
|
算法 BI
数位统计DP
复习acwing算法基础课的内容,本篇为讲解基础算法:动态规划——数位统计DP,关于时间复杂度:目前博主不太会计算,先鸽了,日后一定补上。
76 0
数位统计DP
Queen on Grid_dp
思想很单纯-> dp Code: 代码解释: dp加上之后,注意进行取模 然后再更新这一个节点的计数(ans)
75 0
Queen on Grid_dp