poj2096--Collecting Bugs(可能性dp第二弹,需求预期)

简介:
Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 2678   Accepted: 1302
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.  
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.  
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.  
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.  
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

给出s个子程序。n种bug。每天能够找出一个bug,该bug是随机的一种bug,在随机的一个程序里,问当找到n种bug,而且在每一个程序中都找到过bug的期望。

dp[i][j],代表由已经在i个子程序中找到过j种bug到最后的期望,求得的dp[0][0]就是结果。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[1200][1200] ;
int main()
{
    int i , j , s , n ;
    scanf("%d %d", &s, &n);
    memset(dp,0,sizeof(dp));
    for(i = s ; i >= 0 ; i--)
    {
        for(j = n ; j >= 0 ; j--)
        {
            if( i == s && j == n ) continue ;
            else if( i == s )
                dp[i][j] = ( (n-j)*1.0/n*dp[i][j+1] + 1.0 ) * n / (n-j) ;
            else if( j == n )
                dp[i][j] = ( (s-i)*1.0/s*dp[i+1][j] + 1.0 ) * s / (s-i) ;
            else
                dp[i][j] = ( (s-i)*1.0*j/(s*n)*dp[i+1][j] + i*(n-j)*1.0/(s*n)*dp[i][j+1] + (s-i)*(n-j)*1.0/(s*n)*dp[i+1][j+1] + 1.0 )*s*n/(s*n-i*j);
        }
    }
    printf("%.4lf\n", dp[0][0]);
    return 0;
}


 

版权声明:本文博客原创文章,博客,未经同意,不得转载。









本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4721863.html,如需转载请自行联系原作者


相关文章
每日一题---1005. K 次取反后最大化的数组和[力扣][Go]
每日一题---1005. K 次取反后最大化的数组和[力扣][Go]
每日一题---1005. K 次取反后最大化的数组和[力扣][Go]
华为机试每日一练--第十二题: 查找组成一个偶数最接近的两个素数
华为机试每日一练--第十二题: 查找组成一个偶数最接近的两个素数
华为机试每日一练--第十二题: 查找组成一个偶数最接近的两个素数
【每日一题Day44】LC1769移动所有球到每个盒子所需要的最小操作数 | 模拟 贡献
思路:将所有球移入盒子i ii所需要的操作数取决于其右侧盒子内的小球和左侧盒子内的小球至其的距离,最终操作数即为距离的累加和。因此盒子i + 1 i+1i+1所需要的操作数,可以由盒子i ii所需要的操作数推出。
66 0
|
存储 测试技术
牛客hot100--BM50---两数之和(简单难度)
牛客hot100--BM50---两数之和(简单难度)
100 0
牛客hot100--BM50---两数之和(简单难度)
牛客hot100--BM88---判断是否为回文字符串(入门难度)
牛客hot100--BM88---判断是否为回文字符串(入门难度)
75 0
牛客hot100--BM88---判断是否为回文字符串(入门难度)
|
算法
【每日算法】AB5 点击消除
【每日算法】AB5 点击消除
82 0
Codeforces1486 C2.Guessing the Greatest (hard version)(交互题+奇怪的二分)
Codeforces1486 C2.Guessing the Greatest (hard version)(交互题+奇怪的二分)
34 0
|
机器学习/深度学习
Codeforces1499——C. Minimum Grid Path(思维+分奇偶+贪心)
Codeforces1499——C. Minimum Grid Path(思维+分奇偶+贪心)
65 0
POJ-2492,A Bug's Life(分类并查集)
POJ-2492,A Bug's Life(分类并查集)
|
算法 Java Python
【每日算法】两种「二分」统计有序数组中 target 出现次数的思路|Python 主题月
【每日算法】两种「二分」统计有序数组中 target 出现次数的思路|Python 主题月