poj1276--Cash Machine(多背包被判刑了)

简介:
Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27804   Accepted: 9915

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,  

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10  

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.  

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.  

Notes:  
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.  

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:  

cash N n1 D1 n2 D2 ... nN DN  

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.  

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.  

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.  

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.  

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

给出n种货币,每种的价值和数量。问可得到最接近case的是多少?
多重背包问题,使用二进制转化为01背包。

从m转化为 12,4,2^(k-1) , m-2^k+1 ; k是由m-2^k+1>0的最大整数得到
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[110000] ;
int m[20] , a[20] ;
int main()
{
    int c , n , i , j , l , k , mm ;
    while(scanf("%d %d", &c, &n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        dp[0] = 1 ;
        for(i = 0 ; i < n ; i++)
            scanf("%d %d", &m[i], &a[i]) ;
        for(i = 0 ; i < n ; i++)
        {
            k = 0 ;
            while( (1<<k) <= m[i] )
                k++ ;
            k-- ;
            if(k == -1) continue ;
            mm = (m[i] - (1<<k) +1  ) * a[i] ;
            for(j = c ; j-mm >= 0 ; j--)
                dp[j] += dp[j-mm] ;
            for(l = 0 ; l < k ; l++)
            {
                mm = (1<<l)*a[i] ;
                for(j = c ; j-mm >= 0 ; j--)
                    dp[j] += dp[j-mm] ;
            }
        }
        for(i = c ; i >= 0 ; i--)
            if( dp[i] )
                break;
        printf("%d\n", i);
    }
    return 0;
}

版权声明:转载请注明出处:http://blog.csdn.net/winddreams






本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/4747446.html,如需转载请自行联系原作者


相关文章
|
5月前
|
Java
hdu1016 Prime Ring Problem【素数环问题(经典dfs)】
hdu1016 Prime Ring Problem【素数环问题(经典dfs)】
24 0
|
6月前
light oj 1231-1232 - 1233- Coin Change 背包
暂时到半懂不懂也没办法讲明白,就不误人子弟了,直接贴代码了。
20 0
|
6月前
poj 3624 Charm Bracelet(简单01背包)
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
19 0
|
6月前
|
C++
poj 2182 Lost Cows(树状数组)
FJ有n头牛,现在它们排成一排,每一头牛都有一个不同的编号(1-n),现在知道从第二头牛开始每头牛左边比自己编号小的牛的数目,让你确定每头牛的编号。
21 0
POJ-3624,Charm Bracelet(01背包)
POJ-3624,Charm Bracelet(01背包)
HDU-1016,Prime Ring Problem(DFS+素数)
HDU-1016,Prime Ring Problem(DFS+素数)
|
知识图谱
POJ-1384,Piggy-Bank(完全背包)
POJ-1384,Piggy-Bank(完全背包)
ZOJ Problem Set - 3758 素数
ZOJ Problem Set - 3758 素数
80 0
[转]POJ3624 Charm Bracelet(典型01背包问题)
来源:https://www.cnblogs.com/jinglecjy/p/5674796.html 题目链接:http://bailian.openjudge.cn/practice/4131/ Time Limit: 1000MS          Memory Limit: 65536K  ...
1207 0

热门文章

最新文章