HDU 4968 Improving the GPA

简介:
Problem Description
Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N
where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them. 


The student’s average GPA in the 4-Point Scale is calculated as follows: GPA = ∑(GPAi) / N
So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale. 
 

Input
The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).
 

Output
For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.
 

Sample Input
 
 
4 75 1 75 2 75 3 75 10
 

Sample Output
 
3.0000 3.0000 2.7500 3.0000 2.6667 3.1667 2.4000 3.2000
Hint
In the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale. For example, Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667 Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667 Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667 Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667

题意:告诉你n个人的平均数,求最大的,最小的平均绩点

思路:简单的DP,dp[i][j]前i个人总分j的最大绩点和

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 105;
const double inf = 90000000.0;

double dp[15][1010], tab[105];
double lp[15][1010];

int main() {
	for (int i = 60; i <= 69; i++)	
		tab[i] = 2.0;
	for (int i = 70; i <= 74; i++)
		tab[i] = 2.5;
	for (int i = 75; i <= 79; i++)	
		tab[i] = 3.0;
	for (int i = 80; i <= 84; i++)
		tab[i] = 3.5;
	for (int i = 85; i <= 100; i++)
		tab[i] = 4.0;

	memset(dp, 0, sizeof(dp));
	for (int i = 60; i <= 100; i++)
		dp[1][i] = tab[i];
	for (int i = 2; i <= 10; i++)
		for (int j = 60; j <= 100; j++)
			for (int k = j; k <= 1000; k++)
				if (dp[i-1][k-j] != 0)
					dp[i][k] = max(dp[i][k], dp[i-1][k-j]+tab[j]);

	for (int i = 0; i <= 10; i++)
		for (int j = 0; j <= 1000; j++)
			lp[i][j] = inf;

	for (int i = 60; i <= 100; i++)
		lp[1][i] = tab[i];

	for (int i = 2; i <= 10; i++)
		for (int j = 60; j <= 100; j++)
			for (int k = j; k <= 1000; k++)
				if (lp[i-1][k-j] != inf)
					lp[i][k] = min(lp[i][k], lp[i-1][k-j]+tab[j]);
	
	int v, n;
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d", &v, &n);
		printf("%.4lf %.4lf\n", lp[n][n*v]/n, dp[n][n*v]/n);
	}
	return 0;
}








本文转自mfrbuaa博客园博客,原文链接:http://www.cnblogs.com/mfrbuaa/p/5082048.html,如需转载请自行联系原作者


相关文章
|
6月前
uva 11991 - Easy Problem from Rujia Liu?
这个题目的意思是输入n个数,m组询问,每组询问包含两个整数k,v,意思是询问整数v第k次出现的位置。
28 0
|
8月前
UVa1531 - Problem Bee
UVa1531 - Problem Bee
34 0
|
8月前
UVa11565 - Simple Equations
UVa11565 - Simple Equations
35 0
|
8月前
UVa389 - Basically Speaking
UVa389 - Basically Speaking
24 0
HDU-1057,A New Growth Industry(理解题意)
HDU-1057,A New Growth Industry(理解题意)
|
Java
2017 Multi-University Training Contest - Team 9 1003&&HDU 6163 CSGO【计算几何】
CSGO Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 127    Accepted Submission(s): 20 Pro...
1384 0

热门文章

最新文章