poj1080--Human Gene Functions(dp:LCS变形)

简介:
Human Gene Functions
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17206   Accepted: 9568

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.  

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.  
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.  

A database search will return a list of gene sequences from the database that are similar to the query gene.  
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.  

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.  
Given two genes AGTGATG and GTTAG, how similar are they?

One of the methods to measure the similarity 
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of 
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal 
length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix. 


denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.  

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):  

AGTGATG  
-GTTA-G  

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the  
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

Source

Taejon 2001
 
变形的lcs。和最长公共子序列的求法是一样的,仅仅是把长度+1。转化为了分数的变化。
注意:对于dp[0][i] , dp[i][0]这两个位置的处理
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[120][120] , l1 , l2 ;
char s1[120] , s2[120] ;
char str[6] = "ACGT " ;
int k[5][5] = { {5,-1,-2,-1,-3},{-1,5,-3,-2,-4},{-2,-3,5,-2,-2},{-1,-2,-2,5,-1},{-3,-4,-2,-1,0} };
int main()
{
    int t , i , j , ii , jj ;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %s", &l1, s1);
        scanf("%d %s", &l2, s2);
        memset(dp,0,sizeof(dp));
        for(i = 1 ; i <= l1 ; i++)
        {
            for(j = 0 ; j < 5 ; j++)
                if( str[j] == s1[i-1] )
                    break;
            dp[i][0] = k[j][4] + dp[i-1][0] ;
        }
        for(i = 1 ; i <= l2 ; i++)
        {
            for(j = 0 ; j < 5 ; j++)
                if( str[j] == s2[i-1] )
                    break;
            dp[0][i] = k[4][j] + dp[0][i-1] ;
        }
        for(i = 1 ; i <= l1 ; i++)
        {
            for(j =1 ; j <= l2 ; j++)
            {
                for(ii = 0 ; ii < 5 ; ii++)
                    if( str[ii] == s1[i-1] ) break;
                for(jj = 0 ; jj < 5 ; jj++)
                    if( str[jj] == s2[j-1] ) break;
                dp[i][j] = max( dp[i-1][j-1]+k[ii][jj],max(dp[i-1][j]+k[ii][4],dp[i][j-1]+k[4][jj]) );
            }
        }
        printf("%d\n", dp[l1][l2]);
    }
    return 0;
}






 
相关文章
|
人工智能 BI
AtCoder Beginner Contest 216 F - Max Sum Counting (降维 背包dp)
AtCoder Beginner Contest 216 F - Max Sum Counting (降维 背包dp)
98 0
|
人工智能
Codeforces1343D - Constant Palindrome Sum + UPC-鸭子游戏 (差分)
Codeforces1343D - Constant Palindrome Sum + UPC-鸭子游戏 (差分)
75 1
洛谷P3855-[TJOI2008]Binary Land(BFS)
洛谷P3855-[TJOI2008]Binary Land(BFS)
|
人工智能
[Codeforces 1579G] Minimal Coverage | dp最小区间覆盖
题意: 给出n个线段,以及一个无限大的坐标轴,第一个线段以0为起点进行放置,后面的线段必须以前一个的终点为起点放置,这就有两种方式,向左向右
|
人工智能 vr&ar
Atcoder--Candy Distribution II--前缀和+map
题目描述 There are N boxes arranged in a row from left to right. The i-th box from the left contains Ai candies. You will take out the candies from some consecutive boxes and distribute them evenly to M children. Such being the case, find the number of the pairs (l,r) that satisfy the following:
77 0
Data Structures and Algorithms (English) - 6-11 Shortest Path [1](25 分)
Data Structures and Algorithms (English) - 6-11 Shortest Path [1](25 分)
90 0
Data Structures and Algorithms (English) - 6-16 Shortest Path [3](25 分)
Data Structures and Algorithms (English) - 6-16 Shortest Path [3](25 分)
83 0
Data Structures and Algorithms (English) - 6-11 Shortest Path [2](25 分)
Data Structures and Algorithms (English) - 6-11 Shortest Path [2](25 分)
103 0
Data Structures and Algorithms (English) - 6-17 Shortest Path [4](25 分)
Data Structures and Algorithms (English) - 6-17 Shortest Path [4](25 分)
90 0