HDU 1076(第n个生日在哪一年)

简介: Problem Description Ignatius was born in a leap year, so he want to know when he could hold his birthday party.

Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

 

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

 

Note:

if year Y is a leap year, then the 1st leap year is year Y.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains two positive integers Y and N(1<=N<=10000).

Output

For each test case, you should output the Nth leap year from year Y.

Sample Input

3

2005 25

1855 12

2004 10000

 

Sample Output

2108

1904

43236

/*
该题N定义为50000RE,100000AC
因为该题year没范围,但因为要可以求第10000个生日,
所以 year的范围也绝对不会是INT_MAX,
考虑到不知year的范围,先试用is_leap(int year) 函数判断
闰年,不用初始化,若超时,再按我这种方法
*/ 
#include<string.h>
#include<stdlib.h>
#define N 100000
int leap[N];
void isleap()
{
    int i,j;
    memset(leap,0,sizeof(leap));
    for(i=1;i<N;i++)
    if(i%4==0&&i%100!=0||i%400==0)
        leap[i]=1;
}
int main()
{
    int i,j,T;
    int year,num,cnt;
    scanf("%d",&T);
    isleap();
    while(T--)
    {
        cnt=0;
        scanf("%d %d",&year,&num);
        for(i=year;cnt<num;i++)
        if(leap[i])
            cnt++;
        printf("%d\n",i-1);
    }
    system("pause");
    return 0;
}
        
    
     

 

目录
相关文章
|
3月前
|
C++
第十三届蓝桥杯B组C++(试题B:顺子日期)
第十三届蓝桥杯B组C++(试题B:顺子日期)
50 0
|
9月前
|
数据采集 程序员 Python
【每周一坑】特殊的生日
好吧,我在跳票的道路上又双叒叕前进了一步……今天终于厚着脸皮来更新【每“周”一坑】啦。感谢在后台孜孜不倦催促我的同学们
|
10月前
[蓝桥杯 2021 省 B2] 特殊年份
[蓝桥杯 2021 省 B2] 特殊年份
93 1
|
12月前
|
存储 算法 索引
Leetcode第一周练习总结(1.1~1.7)
Leetcode第一周练习总结(1.1~1.7)
|
存储 程序员 Python
使用Python实现自动生日祝福
使用Python实现自动生日祝福
207 0
使用Python实现自动生日祝福
|
C++
蓝桥杯练习题一 - 生日蜡烛(c++)
蓝桥杯练习题一 - 生日蜡烛(c++)
116 0
PTA 1041 考试座位号 (15 分)
每个 PAT 考生在参加考试时都会被分配两个座位号,一个是试机座位,一个是考试座位。
78 0
【八月】每日一题 - 1417. 重新格式化字符串
【八月】每日一题 - 1417. 重新格式化字符串
61 0
|
前端开发 程序员
面试周连续剧之被虐成‘狗’
接着继续来话面试周的经历,时间来到面试周的第二天,提前总结一下当天的面试以被虐为主基调,虽然也有意外收获,但是当天的主基调就是被面试官虐,而不是“反杀”面试官,那么马上开启整天的经历吧。
106 0
面试周连续剧之被虐成‘狗’
打印日期(华中科技大学考研机试)
打印日期(华中科技大学考研机试)
70 0
打印日期(华中科技大学考研机试)