HDOJ 1032(POJ 1207) The 3n + 1 problem

简介: DescriptionProblems in Computer Science are often classified as belonging to a certain class of problems (e.

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:

    1.       input n



    2.       print n



    3.       if n = 1 then STOP



    4.               if n is odd then   n <-- 3n+1



    5.               else   n <-- n/2



    6.       GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
Sample Input

1 10
100 200
201 210
900 1000
Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

#include <stdio.h>
#include <stdlib.h>
int arr[1000010];
int suan(int x,int num){
    if(x==1)
        return num+1;
    if(x%2==0)
        suan(x/2,num+1);
    else
        suan(3*x+1,num+1);
}
int main(){
    int m,n;
    while(scanf("%d %d",&n,&m)==2){
        int i;
        bool First=true;
        int maxx=0;
        if(n>m){
            n=n+m;
            m=n-m;
            n=n-m;
            First=false;
        }

        for(i=n;i<=m;i++){
            arr[i]=suan(i,0);
            if(maxx<arr[i])
                maxx=arr[i];
        }
        if(First)
        printf("%d %d %d\n",n,m,maxx);
        else{
            printf("%d %d %d\n",m,n,maxx);
        }
    }
    return 0;
}

目录
相关文章
|
数据挖掘
HDOJ 1032(POJ 1207) The 3n + 1 problem
HDOJ 1032(POJ 1207) The 3n + 1 problem
110 0
|
Java 文件存储
HDOJ(HDU) 2132 An easy problem
HDOJ(HDU) 2132 An easy problem
75 0
|
Java 文件存储
HDOJ(HDU) 2123 An easy problem(简单题...)
HDOJ(HDU) 2123 An easy problem(简单题...)
105 0
HDOJ(HDU) 1673 Optimal Parking
HDOJ(HDU) 1673 Optimal Parking
101 0
HDOJ/HDU 2568 前进(简单题)
HDOJ/HDU 2568 前进(简单题)
103 0
HDOJ(HDU) 2153 仙人球的残影(谜一样的题、、、)
HDOJ(HDU) 2153 仙人球的残影(谜一样的题、、、)
93 0
HDOJ1002题A + B Problem II,2个大数相加
HDOJ1002题A + B Problem II,2个大数相加
88 0
HDOJ(HDU) 1570 A C
HDOJ(HDU) 1570 A C
80 0
HDOJ(HDU) 1570 A C
HDOJ(HDU) 1678 Shopaholic
HDOJ(HDU) 1678 Shopaholic
88 0