HDOJ 2131 Probability

简介: Problem Description Mickey is interested in probability recently. One day , he played a game which is about probability with mini.

Problem Description
Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter “a” and the word “apple”. the probability of this case is 0.20000.

Input
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.

Output
For each test case, print the probability rounded to five digits after the decimal point.

Sample Input
a apple
c Candy
a banana

Sample Output
0.20000
0.20000
0.50000

题意:
先输入一个字符,再输入一个字符串,然后输出该字符在字符串中占多少比例;保留5位小数。
属于简单题。

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            String a = sc.next();
            String strs = sc.next();
            int anum = 0;
            String strss = "";
            for(int i=0;i<strs.length();i++){
                strss = strs.charAt(i)+"";
                if(a.equalsIgnoreCase(strss)){
                    anum++;
                }
            }
            double num = (double)((double)anum/(double)strs.length());
            System.out.printf("%.5f\t\n",num);
        }
    }
}
目录
相关文章
HDOJ 2131 Probability
HDOJ 2131 Probability
76 0
HDOJ 1017 A Mathematical Curiosity
HDOJ 1017 A Mathematical Curiosity
88 0
HDOJ 1098 Ignatius's puzzle
HDOJ 1098 Ignatius's puzzle
99 0
HDOJ 2058 The sum problem
HDOJ 2058 The sum problem
89 0
HDOJ 2101 A + B Problem Too
HDOJ 2101 A + B Problem Too
84 0
HDOJ 1002 A + B Problem II
HDOJ 1002 A + B Problem II
96 0
HDOJ 1001Sum Problem
HDOJ 1001Sum Problem
91 0
|
Java
HDOJ 1000 A + B Problem
HDOJ 1000 A + B Problem
88 0
|
人工智能
HDOJ 1028 Ignatius and the Princess III(递推)
HDOJ 1028 Ignatius and the Princess III(递推)
98 0
HDOJ 1405 The Last Practice
HDOJ 1405 The Last Practice
70 0