HDOJ 1194 Beat the Spread!(简单题)

简介: Problem Description Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunct...

Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing “impossible”. Recall that football scores are always non-negative integers.

Sample Input
2
40 20
20 40

Sample Output
30 10
impossible

题意:输入2个数 a,b。
a是x,y的和,b是x,y的差。(x,y只能为正整数或者0)
如果x,y中出现了负数就输出impossible。
要注意的是x=(a+b)/2;y=(a-b)/2;
因为x,y是正整数,所以(a+b)%2==0且(a-b)%2==0;

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int a = sc.nextInt();
            int b = sc.nextInt();
            int x=(a+b)/2;
            int y=(a-b)/2;
            if(x<0||y<0||(a+b)%2!=0||(a-b)%2!=0){
                System.out.println("impossible");
            }else{
                System.out.println(x+" "+y);
            }
        }
    }
}
目录
相关文章
|
6月前
hdoj 4706 Children's Day
题目意思就是用a-z组成一个N,然后到z后又跳回a,输出宽从3到10的N。
28 0
HDOJ 1194 Beat the Spread!(简单题)
HDOJ 1194 Beat the Spread!(简单题)
101 0
HDOJ 1017 A Mathematical Curiosity
HDOJ 1017 A Mathematical Curiosity
88 0
HDOJ 2055 An easy problem
HDOJ 2055 An easy problem
89 0
HDOJ 1002 A + B Problem II
HDOJ 1002 A + B Problem II
96 0
HDOJ 2101 A + B Problem Too
HDOJ 2101 A + B Problem Too
84 0
HDOJ 2131 Probability
HDOJ 2131 Probability
76 0
HDOJ 1040 As Easy As A+B
HDOJ 1040 As Easy As A+B
83 0
HDOJ 1157 Who's in the Middle
HDOJ 1157 Who's in the Middle
69 0
|
Java
HDOJ 1000 A + B Problem
HDOJ 1000 A + B Problem
88 0