HDOJ 1326 Box of Bricks(简单题)

简介: Problem Description Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height.

Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. Look, I've built a wall!'', he tells his older sister Alice.Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output
For each set, first print the number of the set, as shown in the sample output. Then print the line “The minimum number of moves is k.”, where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input
6
5 2 4 1 7 5
0

Sample Output
Set #1
The minimum number of moves is 5.

题目很简单:就是先输入一个数n,然后再接n个数,
如果n为0,就结束输入。
然后求n个数的平均数,再求出这n个数中(比平均数大的数一共比平均数大多少的和)比平均数小的数一共比平均数小多少的和。
这个和就是要求的。

import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int tp=1;
        while(sc.hasNext()){
            int n = sc.nextInt();
            if(n==0){
                return ;
            }
            int[] num = new int[n];
            int sum=0;
            for(int i=0;i<n;i++){
                num[i] = sc.nextInt();
                sum+=num[i];
            }

            int s = sum/n;

            int times = 0;
            for(int i=0;i<n;i++){
                if(num[i]<s){
                    times+=s-num[i];
                }
            }
            System.out.println("Set #"+(tp++));
            System.out.println("The minimum number of moves is "+times+".");
            System.out.println();
        }

    }

}
目录
相关文章
|
6月前
hdoj 4706 Children's Day
题目意思就是用a-z组成一个N,然后到z后又跳回a,输出宽从3到10的N。
29 0
|
6月前
hdoj 2089 不要62
这题数据量相对比较小,可以暴力打表解决。不过我这里用数位dp 刚开始学数位dp,参考了别人的代码。
22 0
HDOJ 1326 Box of Bricks(简单题)
HDOJ 1326 Box of Bricks(简单题)
88 0
HDOJ 1326 Box of Bricks(简单题)
HDOJ 1157 Who's in the Middle
HDOJ 1157 Who's in the Middle
69 0
|
Java
HDOJ 1312题Red and Black
HDOJ 1312题Red and Black
103 0
HDOJ 1312 (POJ 1979) Red and Black
HDOJ 1312 (POJ 1979) Red and Black
90 0
HDOJ(HDU) 2088 Box of Bricks(平均值)
HDOJ(HDU) 2088 Box of Bricks(平均值)
66 0
HDOJ(HDU) 2088 Box of Bricks(平均值)
HDOJ 2052 Picture
HDOJ 2052 Picture
80 0
HDOJ 1194 Beat the Spread!(简单题)
HDOJ 1194 Beat the Spread!(简单题)
101 0
HDOJ 2075 A|B?
HDOJ 2075 A|B?
64 0