HDOJ/HDU 2700 Parity(奇偶判断~)

简介: Problem Description A bit string has odd parity if the number of 1’s is odd. A bit string has even parity if the number of 1’s is even.

Problem Description
A bit string has odd parity if the number of 1’s is odd. A bit string has even parity if the number of 1’s is even.Zero is considered to be an even number, so a bit string with no 1’s has even parity. Note that the number of
0’s does not affect the parity of a bit string.

Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only “#” that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter ‘e’ or a lowercase letter ‘o’.

Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was ‘e’) or odd parity (if the letter was ‘o’).

Sample Input
101e
010010o
1e
000e
110100101o
#

Sample Output
1010
0100101
11
0000
1101001010

英文题~看懂题意就ok了。
e代表的是偶数奇偶性校验。
o代表的是奇数奇偶性校验。
0代表是。1代表否~
其实就是判断1的个数~

import java.util.Scanner;

/**
 * @author 陈浩翔
 */
public class Main{

    public static void main(String[] args) {
        Scanner sc= new Scanner(System.in);
        while(sc.hasNext()){
            String str = sc.next();
            if(str.equals("#")){
                return ;
            }
            int num=0;
            for(int i=0;i<str.length()-1;i++){
                if(str.charAt(i)=='1'){
                    num++;
                }
            }
            if(num%2==0){//1出现的次数为偶数
                if(str.charAt(str.length()-1)=='e'){//偶数奇偶校验
                    //0代表判断正确
                    System.out.println(str.substring(0, str.length()-1)+'0');
                }else{
                    System.out.println(str.substring(0, str.length()-1)+'1');
                }
            }else{
                if(str.charAt(str.length()-1)=='o'){//奇数奇偶校验
                    //0代表判断正确
                    System.out.println(str.substring(0, str.length()-1)+'0');
                }else{
                    System.out.println(str.substring(0, str.length()-1)+'1');
                }
            }
        }
    }
}
目录
相关文章
|
6月前
hdoj 1028/poj 2704 Pascal's Travels(记忆化搜索||dp)
有个小球,只能向右边或下边滚动,而且它下一步滚动的步数是它在当前点上的数字,如果是0表示进入一个死胡同。求它从左上角到右下角到路径数目。 注意, 题目给了提示了,要用64位的整数。
22 0
HDU-1016,Prime Ring Problem(DFS+素数)
HDU-1016,Prime Ring Problem(DFS+素数)
HDOJ/HDU 2700 Parity(奇偶判断~)
HDOJ/HDU 2700 Parity(奇偶判断~)
107 0
HDOJ/HDU 2163 Palindromes(判断回文串~)
HDOJ/HDU 2163 Palindromes(判断回文串~)
73 0
|
C语言
HDOJ 1016 Prime Ring Problem素数环【深搜2】
HDOJ 1016 Prime Ring Problem素数环【深搜】
78 0
HDOJ 1016 Prime Ring Problem素数环【深搜】
HDOJ 1016 Prime Ring Problem素数环【深搜】
89 0
HDOJ 1016 Prime Ring Problem素数环【深搜】
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
214 0
HDOJ(HDU) 1562 Guess the number(水题,枚举就行)
HDOJ(HDU) 1562 Guess the number(水题,枚举就行)
97 0
|
Java
HDOJ/HDU 1297 Children’s Queue(推导~大数)
HDOJ/HDU 1297 Children’s Queue(推导~大数)
109 0
|
Go
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
HDOJ(HDU) 1977 Consecutive sum II(推导、、)
87 0