HDOJ/HDU 1865 1sting(斐波拉契+大数~)

简介: Problem Description You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there.

Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.

Output
The output contain n lines, each line output the number of result you can get .

Sample Input
3
1
11
11111

Sample Output
1
2
8

题意:
若干个1,可以选择相邻两个合并成2。问有多少种可能的结果。

分析:递推加大数~

递推公式为db[i] = db[i-1] + db[i-2],斐波那契数列。
怎么推导出来的呢~~~我能说我是看出来的麽~

设有n个1,可以构成f(n)种。则加一个1的时候,前面n种仍然成立 f(n+1)=f(n)+*;
第n+1个1和第n个1相加构成2,前面n-1个1可以组合的个数。 f(n+1)=f(n)+f(n-1);

大数~用java很好过的~c的话,只能用数组模拟了。

import java.math.BigInteger;
import java.util.Scanner;

public class Main{

    static BigInteger db[] = new BigInteger[201];
    public static void main(String[] args) {
        dabiao();
        Scanner sc = new Scanner(System.in);
        int t=sc.nextInt();
        while(t-->0){
            String str =sc.next();
            int n =str.length();
            System.out.println(db[n]);
        }
    }
    private static void dabiao() {
        db[1]=new BigInteger("1");
        db[2]=new BigInteger("2");
        for(int i=3;i<db.length;i++){
            db[i]=db[i-1].add(db[i-2]);
        }
    }
}
目录
相关文章
|
6月前
codeforces 272C. Dima and Staircase(线段树)
题目很长,看加猜加谷歌翻译才看懂了题目。每级台阶的宽都是1,但高不同,并且告诉你了,然后给你m个箱子,长和宽都告诉你,把箱子靠左放,求箱子的底部有多高。
17 0
|
2月前
|
C++
【PTA】​ L1-080 乘法口诀数列​(C++)
【PTA】​ L1-080 乘法口诀数列​(C++)
39 0
【PTA】​ L1-080 乘法口诀数列​(C++)
|
人工智能 vr&ar Perl
codeforces1509 C. The Sports Festival (区间DP)
codeforces1509 C. The Sports Festival (区间DP)
84 0
周娟老师讲授的快速幂:整数快速幂、矩阵快速幂。
周娟老师讲授的快速幂:整数快速幂、矩阵快速幂。
79 0
蓝桥杯-Fibonacci数列(打表)
蓝桥杯-Fibonacci数列(打表)
|
Java
HDOJ/HDU 1865 1sting(斐波拉契+大数~)
HDOJ/HDU 1865 1sting(斐波拉契+大数~)
79 0
|
Java
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
HDOJ/HDU 5686 Problem B(斐波拉契+大数~)
81 0
|
Java
HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)
HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)
82 0
|
Java
1-2求斐波拉契数
求斐波拉契数 斐波拉契数为,Fib(N) = Fib(N-1)+Fib(N-2) F(0)=F(1)=1 用Java编写能求Fib(N)的程序 输入为N,须输出Fib(N) 如输入 3 输出: 3 import java.
1119 0