HDOJ/HDU 1073 Online Judge(字符串处理~)

简介: Problem Description Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System.

Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user’s result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return “Accepted”, else if the only differences between the two files are spaces(’ ‘), tabs(‘\t’), or enters(‘\n’), the Judge System should return “Presentation Error”, else the system will return “Wrong Answer”.

Given the data of correct output file and the data of user’s result file, your task is to determine which result the Judge System will return.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user’s result file. Both of them are starts with a single line contains a string “START” and end with a single line contains a string “END”, these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output
For each test cases, you should output the the result Judge System should return.

Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1 + 2 = 3
END

Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error

就是输入输出,简单的判断PE,WA,AC这几种情况。

START是开始输入了,
END是结束输入了。数据在这个之间!
每一组有2个 START和END。
就是判断这2个之间的数据是PE,WA还是AC。

分析:
用2字符串分别存储这2个需要比较的数据,遇到换行需要在字符串中加入’\n’。
先看这2个字符串是不是相等,如果相等,就是AC。
不相等,再来判断是PE还是WA。

import java.util.Scanner;
/**
 * @author 陈浩翔
 *
 * 2016-5-26
 */
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        sc.nextLine();
        while (t-- > 0) {
            String a = "";
            String b = "";
            while (true) {
                String str = sc.nextLine();
                if ("END".equals(str)) {
                    break;
                }
                if ("START".equals(str)) {
                    continue;
                }
                a=a+str;
                a=a+"\n";
            }

            while (true) {
                String str = sc.nextLine();
                if ("END".equals(str)) {
                    break;
                }
                if ("START".equals(str)) {
                    continue;
                }
                b=b+str;
                b=b+"\n";
            }
            int con = 0;// -1--PE,0--WA,1--AC

//          System.out.println(a);
//          System.out.println(a.length());
//          System.out.println(b);
//          System.out.println(b.length());

            if(a.equals(b)){
                con=1;
            }else{
                con=-1;
                String stra="";
                for(int i=0;i<a.length();i++){
                    if(a.charAt(i)==' '||a.charAt(i)=='\t'||a.charAt(i)=='\n'){
                        continue;
                    }
                    stra=stra+a.charAt(i);
                }
                String strb="";
                for(int i=0;i<b.length();i++){
                    if(b.charAt(i)==' '||b.charAt(i)=='\t'||b.charAt(i)=='\n'){
                        continue;
                    }
                    strb=strb+b.charAt(i);
                }
//              System.out.println(stra);
//              System.out.println("-------------");
//              System.out.println(strb);
                if(stra.equals(strb)){
                    con=-1;
                }else{
                    con=0;
                }
            }


            if(con==0){
                System.out.println("Wrong Answer");
            }else if(con==-1){
                System.out.println("Presentation Error");
            }else{
                System.out.println("Accepted");
            }
        }
    }
}
目录
相关文章
|
存储
HDOJ/HDU 1073 Online Judge(字符串处理~)
HDOJ/HDU 1073 Online Judge(字符串处理~)
77 0
|
索引
HDOJ/HDU 2567 寻梦(字符串简单处理)
HDOJ/HDU 2567 寻梦(字符串简单处理)
68 0
|
安全 数据安全/隐私保护
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
HDOJ/HDU 1039 Easier Done Than Said?(字符串处理~)
83 0
|
Web App开发 Java 数据安全/隐私保护
HDOJ(HDU) 1563 Find your present!(异或)
HDOJ(HDU) 1563 Find your present!(异或)
215 0
HDOJ(HDU) 1491 Octorber 21st
HDOJ(HDU) 1491 Octorber 21st
100 0
HDOJ(HDU) 1491 Octorber 21st
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
HDOJ/HDU 1075 What Are You Talking About(字符串查找翻译~Map)
114 0
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
HDOJ(HDU) 1898 Sempr == The Best Problem Solver?(水题、、、)
100 0
HDOJ(HDU) 2061 Treasure the new start, freshmen!(水题、)
HDOJ(HDU) 2061 Treasure the new start, freshmen!(水题、)
109 0
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
102 0
HDOJ/HDU 2163 Palindromes(判断回文串~)
HDOJ/HDU 2163 Palindromes(判断回文串~)
73 0

热门文章

最新文章