HDOJ/HDU 1328 IBM Minus One(水题一个,试试手)

简介: Problem Description You may have heard of the book ‘2001 - A Space Odyssey’ by Arthur C. Clarke, or the film of the same name by Stanley Kubrick.

Problem Description
You may have heard of the book ‘2001 - A Space Odyssey’ by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don’t tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name ‘HAL’ actually meant. Some thought that it might be an abbreviation for ‘Heuristic ALgorithm’. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get … IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

Input
The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

Output
For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing ‘Z’ by ‘A’.

Print a blank line after each test case.

Sample Input
2
HAL
SWERC

Sample Output
String #1
IBM

String #2
TXFSD

题意就是:输入一个大写的字符串,输出每一个大写字母后的一个大写字母。
如果遇到Z就输出A。
注意每一个测试后都有一个空行。

水题一个!

import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        int ti=0;
        while(t-->0){
            String str = sc.next();
            System.out.println("String #"+(++ti));
            for(int i=0;i<str.length();i++){
                if(str.charAt(i)=='Z'){
                    System.out.print("A");
                }else{
                    System.out.print((char)(str.charAt(i)+1));
                }
            }
            System.out.println();
            System.out.println();
        }
    }
}
目录
相关文章
codeforces327——A. Flipping Game(前缀和)
codeforces327——A. Flipping Game(前缀和)
63 0
HDOJ/HDU 1328 IBM Minus One(水题一个,试试手)
HDOJ/HDU 1328 IBM Minus One(水题一个,试试手)
81 0
HDOJ/HDU 1256 画8(绞下思维~水题)
HDOJ/HDU 1256 画8(绞下思维~水题)
87 0
HDOJ(HDU) 1408 盐水的故事
HDOJ(HDU) 1408 盐水的故事
167 0
HDOJ(HDU) 2520 我是菜鸟,我怕谁(等差数列)
HDOJ(HDU) 2520 我是菜鸟,我怕谁(等差数列)
95 0
HDOJ(HDU) 1799 循环多少次?(另类杨辉三角)
HDOJ(HDU) 1799 循环多少次?(另类杨辉三角)
83 0
HDOJ(HDU) 1799 循环多少次?(另类杨辉三角)
HDOJ(HDU) 1407 测试你是否和LTC水平一样高(暴力)
HDOJ(HDU) 1407 测试你是否和LTC水平一样高(暴力)
85 0
HDOJ/HDU 2537 8球胜负(水题.简单的判断)
HDOJ/HDU 2537 8球胜负(水题.简单的判断)
85 0
HDOJ(HDU) 2078 复习时间
HDOJ(HDU) 2078 复习时间
106 0