HDOJ/HDU 2163 Palindromes(判断回文串~)

简介: Problem Description Write a program to determine whether a word is a palindrome. A palindrome is a sequence of characters that is identica...

Problem Description
Write a program to determine whether a word is a palindrome. A palindrome is a sequence of characters that is identical to the string when the characters are placed in reverse order. For example, the following strings are palindromes: “ABCCBA”, “A”, and “AMA”. The following strings are not palindromes: “HELLO”, “ABAB” and “PPA”.

Input
The input file will consist of up to 100 lines, where each line contains at least 1 and at most 52 characters. Your program should stop processing the input when the input string equals “STOP”. You may assume that input file consists of exclusively uppercase letters; no lowercase letters, punctuation marks, digits, or whitespace will be included within each word.

Output
A single line of output should be generated for each string. The line should include “#”, followed by the problem number, followed by a colon and a space, followed by the string “YES” or “NO”.

Sample Input
ABCCBA
A
HELLO
ABAB
AMA
ABAB
PPA
STOP

Sample Output

#1: YES
#2: YES
#3: NO
#4: NO
#5: YES
#6: NO
#7: NO


就是简单的判断回文串的问题,遇到STOP结束程序。

import java.util.Scanner;

/**
 * @author 陈浩翔
 * 2016-6-5
 */
public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =1;
        while(sc.hasNext()){
            String str =sc.next();
            if("STOP".equals(str)){
                return;
            }
            System.out.print("#"+(t++)+": ");
            boolean isProgram = true;
            for(int i=0,j=str.length()-1;i<j;i++,j--){
                if(str.charAt(i)!=str.charAt(j)){
                    isProgram=false;
                    break;
                }
            }
            if(isProgram){
                System.out.println("YES");
            }else{
                System.out.println("NO");
            }

        }
    }
}
目录
相关文章
|
5月前
Palindromes(判断回文串)
Palindromes(判断回文串)
27 0
|
6月前
hdoj 1028/poj 2704 Pascal's Travels(记忆化搜索||dp)
有个小球,只能向右边或下边滚动,而且它下一步滚动的步数是它在当前点上的数字,如果是0表示进入一个死胡同。求它从左上角到右下角到路径数目。 注意, 题目给了提示了,要用64位的整数。
24 0
|
6月前
|
算法
poj 1159 Palindrome(最长公共子串)
关于求最长公共子串, 用到的是动态规划
15 0
HDU 4632 Palindrome subsequence(动态规划)
HDU 4632 Palindrome subsequence(动态规划)
55 0
HDU 4632 Palindrome subsequence(动态规划)
HDOJ/HDU 2163 Palindromes(判断回文串~)
HDOJ/HDU 2163 Palindromes(判断回文串~)
73 0
HDOJ/HDU 2700 Parity(奇偶判断~)
HDOJ/HDU 2700 Parity(奇偶判断~)
108 0
|
索引
HDOJ/HDU 2567 寻梦(字符串简单处理)
HDOJ/HDU 2567 寻梦(字符串简单处理)
68 0
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
HDOJ/HDU 1062 Text Reverse(字符串翻转~)
102 0
|
Java
HDOJ/HDU 2087 剪花布条(indexOf()应用~~)
HDOJ/HDU 2087 剪花布条(indexOf()应用~~)
104 0
HDOJ(HDU) 2161 Primes(素数打表)
HDOJ(HDU) 2161 Primes(素数打表)
85 0