Ubuntu 12.04 使用Eclipse搭建C/C++编译环境

  1. 云栖社区>
  2. 博客>
  3. 正文

Ubuntu 12.04 使用Eclipse搭建C/C++编译环境

double2li 2015-07-27 23:06:00 浏览617
展开阅读全文

首先是安装Eclipse,方法有两种:
       第一种是通过Ubuntu自带的程序安装功能安装Eclipse,应用程序->Ubtuntu软件中心,搜Eclipse安装即可。
       第二种方法是用命令:应用程序->附件->终端
                                       然后输入(中间可能需要你输入密码):
                                       sudo apt-get install eclipse
                                       sudo apt-get install eclipse-pde
                                       sudo apt-get install eclipse-jdt
       解释:
       这个命令是在解决安装CDT(也就是能编译C/C++代码的插件)问题时搜到的一个博文里面的,其原文地址为:ubuntu上使用eclipse进行C/C++代码编译
       对于第一次接触Linux的人说,也许不知道怎么使用命令,或者为什么使用命令。其实我也不是特别清楚,但我想跟系统有关吧,像Windows安装软件, 都是exe格式的,然后双击,下一步下一步就可以,但是Linux应该是为了安全考虑或者什么的,需要使用命令来安装。 Ubuntu算是好的了,安装软件相对而言比较方便。像我刚开始耍的fedora,安装软件,简直让人崩溃,总是会少点依赖的库。使用命令安装软件,先要 打开,终端(相当于DOS,或者说Windows附件里面的命令提示符),终端在应用程序->附件->终端。在终端里面输入密码,不像 Windows那样,会有显示,比如像*那样的。如果在输入密码的时候,终端无任何符号显示,别担心,其实你刚才输入的都已经在终端上了,只是没有显示而 已。继续输就是了,然后按下Enter键。
       注意:
       使用第一种方法安装时候,在安装CDT插件过程中,有可能会出现下面的错误
       An error occurred while installing the items
       session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]org.eclipse.ant.ui 3.4.1.v20090901_r351, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
       The artifact file for osgi.bundle,org.eclipse.ant.ui,3.4.1.v20090901_r351 was not found.
       我搜了一下,说是eclipse-pde或是eclipse-jdt没安装上。其说明的网址如下:https://bugs.launchpad.net /ubuntu/+source/eclipse/+bug/477944。全英文的。所以,如果使用第一种方法的,最好,再在终端输入命令:
       sudo apt-get install eclipse-pde
       sudo apt-get install eclipse-jdt

       再安装CDT插件,方法如下:
       1、启动eclipse,
       2、选择Help->Install New Software...,在Work with的框框下复制下面的地址:  http://download.eclipse.org/releases/galileo
       3、选择Collaboration->Mylyn Bridge: C/C++ Development,安装,重启eclipse。
       4、同上述2、3,选择Programming Languages->Eclipse C/C++ Development,都选上吧,现在硬盘不贵的。重启eclipse,试试吧,有tutorial的。
       注意:
       在安装Mylyn Bridge: C/C++ Development,如果直接选择安装Eclipse C/C++ Development,会出现如下错误:
       Cannot complete the install because one or more required items could not be found.
       Software being installed: Mylyn Bridge: C/C++ Development 5.1.0.200909110608 (org.eclipse.cdt.mylyn.feature.group 5.1.0.200909110608)
       Missing requirement: Mylyn Bridge: C/C++ Development 5.1.0.200909110608   (org.eclipse.cdt.mylyn.feature.group 5.1.0.200909110608) requires 'org.eclipse.mylyn.context.core 3.0.0' but it could not be found

       注意:要记得安装C++必要工具,安装的是GCC工具链,Make等一系列开发工具,命令如下:
   
sudo apt-get install build-essential
       要不然#include头文件的时候,会出现提示:Unresolved inclusion: <iostream>

       好了,Ubuntu下面,安装Eclipse,同时装CDT插件,完美解决了,下面是我无意间搜到的一个帖子(CSDN的),有对CDT相关的优化设置。 里面说Eclipse的CDT智能编辑相当强大,速度爆快。而其针对代码编辑的易操作性,可能是目前所有C++编辑器里最好用的! 其重构、函数实现,都非常好用。这些是VS(不借助VC助手)和C::B所不能的。 
      
       呵呵,是不是的,我也不知道,不过看其发贴人,还有回帖人,都是强人,我想应该不会有很大的出入吧~既然如此,就用着玩玩咯。而且,感觉在Linux下 面,做C/C++的编程,Eclipse的IDE很不错。我原来玩过一段时间的eclipse,所以对这个环境还是比较熟悉。
      
       好了,写完了,如果搜到这篇文章的人,需要安装这个环境,中间出了什么问题了。可以留言,说不定能帮忙解决哈~大家都是新手,讨论讨论~
       同时也搜到一篇不错的Linux编写C/C++的一个教程,直接点击即可:Eclipse CDT 构建第一个项目
       
       刚按照上面csdn的帖子对eclipse+CDT进行了一些优化,发现有些还不不必要的,而且那个帖子有点乱,我重新整理一番,如下:
       
       一、C/C++环境配置:Window - Preferences - C/C++ 
       1、Appearance,选中Group method definitions in the Outline view
       2、 Code Style,通过New来新建一个代码风格,命名为qpsoft,且初始化为BSD/Allmain,然后按习惯修改一些细节。我建议是采用默认的,或许是我过去编Java编写习惯的原因。可按自己的意愿来。
       3、Editor - Content Assist - Auto-Activation - Delay(ms),原值为500,改为100,则智能提示速度将非常快!
       4、Indexer,清空Files to index up-front的内容,修改Cache limits的值,尽可能大,可以提高速度!
       
       二、修改智能提示快捷键:
       Window - Preferences - General - Keys,输入Content,找到Content Assist,在Binding中修改为Shift+Space,要顺手的多。
       我觉得这个可以按照自己的习惯来,呵呵。

       三、其他设置
       1. Window - Preferences - General - Editors - Text Editors,选中Show line numbers,设置Print margin column为110
       2. Window - Preferences - General - Workspace,取消Build automatically,选中Save automatically before build
       对于这个设置,我有点不明白,不过我也按照他这样设置了。如有明白的,看到这篇文章,望留言解答。

       四、通过插件扩展功能
       1. 支持Subversion:Eclipse官方出品,主页位于http://www.eclipse.org/subversive/。
       在安装时可以通过Help->Install New Software...,在work with框框复制地址:http://download.eclipse.org/technology/subversive/0.7/update- site/  

网友评论

登录后评论
0/500
评论
double2li
+ 关注