Robot Framework安装指南

  1. 云栖社区>
  2. 博客>
  3. 正文

Robot Framework安装指南

方倍工作室 2012-05-10 15:52:00 浏览501
展开阅读全文

安装软件下载列表:


2012年5月15日更新

1.python 2.7
http://www.python.org/download/
http://www.python.org/ftp/python/2.7.3/python-2.7.3.msi
-------------------------------------------------------------------------------------------------

2.wxPython
http://www.wxpython.org/download.php
http://downloads.sourceforge.net/wxpython/wxPython2.8-win32-unicode-2.8.12.1-py27.exe
-------------------------------------------------------------------------------------------------

3.robot framework
http://code.google.com/p/robotframework/downloads/list
http://robotframework.googlecode.com/files/robotframework-2.7.1.win32.exe

robotframework-2.7.1.jar 2.7.1: Standalone JAR distribution (contains Jython) Featured Mar 26 Mar 26 15.2 MB 502
robotframework-2.7.1.win32.exe 2.7.1: Graphical installer for 32bit Windows Featured Mar 26 Mar 26 699 KB 1145
robotframework-userguide-2.7.1.zip 2.7.1: User Guide (also available online) Featured
robotframework-quickstart-20090113.zip
------------------------------------------------------------------------------------------------

4.robot framework ride
https://github.com/robotframework/RIDE/downloads
https://github.com/downloads/robotframework/RIDE/robotframework-ride-0.44.win32.exe
-------------------------------------------------------------------------------------------------

5.robot framework seleniumlibrary
https://github.com/rtomac/robotframework-selenium2library/downloads
https://github.com/downloads/rtomac/robotframework-selenium2library/robotframework-selenium2library-1.0.0.win32.exe
https://github.com/downloads/rtomac/robotframework-selenium2library/robotframework-selenium2library-1.0.0-demo.zip
-------------------------------------------------------------------------------------------------

 

文章内容包括:

 

如何安装Robot Framework的准备环境

如何安装Robot Framework

如何安装用例编写集成环境Ride

  • 安装python

Robot Framework是用Python语言写的,所以在安装Robot Framework以前必须安装Python环境

Robot Framework只支持python的2.x版本,我使用的是2.6.6版本,2.71版和2.72版也经过测试没有问题。

 

通过下面链接进入2.6.6页面

http://www.python.org/getit/releases/2.6.6/

(python页面经常被和谐,官网打不开的话,从这个FTP进去,有各个版本的python可供下载。 http://www.python.org/ftp/python/  ) 

根据你的windows版本选择安装包,如果你使用32位的windows,选

Windows x86 MSI Installer (2.6.6) (sig)

 

下载后一路Next安装。

安装后注意把python目录本身和它的子目录Script加入到环境变量的Path项。如 D:\Python26 和 D:\Python26\Scripts

 

Tip:如果你已经装了3.X,看这篇文章(多版本python共存问题解决)

http://www.newsgroups-index.com/post/1004807631_705__Re: windows�¶�汾����.html  (链接是好的,进不去你自己想办法)

 

  • 安装Jython

如果你需要使用Java开发拓展测试类库,则必须安装Jython

Jython和python的区别可见下文:

http://developer.51cto.com/art/200907/136978.htm

 

安装Jython需要Jdk5或以上,可以在命令行模式下用 Java -version 指令查看JAVA的版本。

如果机子上没有,可以自己去Java的官网下载安装

 

JDK1.6官方下载_JDK6官方下载地址:http://www.java.net/download/jdk6/6u10/promoted/b32/binaries/jdk-6u10-rc2-bin-b32-windows-i586-p-12_sep_2008.exe

 

 

Jython的下载页面是如下链接:

http://www.jython.org/downloads.html

选择2.5.2及以上版本下载。

 

安装很简单:在命令行模式下,进入下载好的jar包目录运行下面指令

 java -jar jython_installer-2.5.2.jar 
  • 安装Robot Framework

建议安装最新的2.6版本,下载Win32版本(64位操作系统可下载64位版本)

http://code.google.com/p/robotframework/downloads/detail?name=robotframework-2.6.0.win32.exe

下载后一路next完成安装。

 

 加入环境变量方法:我的电脑上点击右键--选择系统-在弹出窗口找到“高级”选项卡-选择右下角的“环境变量”-在系统变量里找到Path项-添加到最后,多个环境变量之间用 “;”  隔开

  • 验证安装是否成功

在命令行输入:

pybot --version 如果成功显示版本号则说明安装成功。

jybot --version 如果成功显示版本号则说明Jython环境也安装成功,可以两条腿走路了。

 

  • 安装Ride

安装Ride前,需要预先安装支撑Ride的运行库wxPython,这个概念有点儿类似Java的Swing库。

进入wxPython的下载页面

http://wxpython.org/download.php#stable

win32选择下面版本(针对与python2.6的,不同版本的python得装不同版本的wxPython,这点需要注意,另外我们得选unicode,不然不能支持中文

wxPython2.8-win32-unicode-py26

 

下载后一路Next安装。

 

安装完wxPython后就可以安装Ride了。

进入Ride的主页,在左下方找到下载链接。(目前最高版本为0.39)

http://code.google.com/p/robotframework-ride/

下载后,一路Next安装到完成。

 

  • 验证RIDE安装成功

在命令行输入:

 ride.py 

如果下面的RIDE界面出现则安装成功,若提示错误则可能是wyPython没有正确安装或者ride.py没有在环境变量pyth中,需要手动添加环境变量(一般Ride.py会自动被安装到python的Scripts目录下。)

 

Robot <wbr>Framework安装指南

 

 

 

 

 

 

 

网友评论

登录后评论
0/500
评论
方倍工作室
+ 关注