用遍历解决某数学题的易语言

  1. 云栖社区>
  2. 博客列表>
  3. 正文

用遍历解决某数学题的易语言

cometwo123 2013-03-02 19:00:00 浏览520 评论0

摘要: 这题出的偏门又刁钻~~ 想了 很久 ~~||||||  理清了头绪 算出 用的爆破 * 192 | 384 | 576 * 219 | 438 | 657 * 273 | 546 | 819 * 327 | 654 | 981 代码 .

这题出的偏门又刁钻~~

想了 很久 ~~|||||| 

理清了头绪 算出 用的爆破


  1. * 192 | 384 | 576
  2. * 219 | 438 | 657
  3. * 273 | 546 | 819
  4. * 327 | 654 | 981

代码


  1. .版本 2
  2. .支持库 spec
  3. .程序集 窗口程序集1
  4. .程序集变量 数组1, 整数型, , "0"
  5. .程序集变量 数组2, 整数型, , "0"
  6. .程序集变量 数组3, 整数型, , "0"
  7. .子程序 _按钮1_被单击
  8. .局部变量 n1, 整数型
  9. .局部变量 m1, 整数型
  10. .局部变量 局变被搜索文字, 文本型
  11. .局部变量 局变搜索文字, 文本型
  12. .局部变量 局变位置, 整数型
  13. .局部变量 t1, 整数型
  14. .局部变量 s1, 整数型
  15. .计次循环首 (999, t1)
  16. 加入成员 (数组1, t1)
  17. .计次循环尾 ()
  18. .计次循环首 (取数组成员数 (数组1), s1)
  19. 加入成员 (数组2, 数组1 [s1] × 2)
  20. 加入成员 (数组3, 数组1 [s1] × 3)
  21. .计次循环尾 ()
  22. .计次循环首 (取数组成员数 (数组1), n1)
  23. .如果真 (数组1 [n1] < 100)
  24. 到循环尾 ()
  25. .如果真结束
  26. .如果真 (数组1 [n1] × 2 = 数组2 [n1] 且 数组1 [n1] × 3 = 数组3 [n1])
  27. 局变被搜索文字 = 到文本 (数组1 [n1]) + 到文本 (数组2 [n1]) + 到文本 (数组3 [n1])
  28. .计次循环首 (10, m1)
  29. 局变搜索文字 = 到文本 (m1 - 1)
  30. 局变位置 = 寻找文本 (局变被搜索文字, 局变搜索文字, , 假)
  31. 局变位置 = 寻找文本 (局变被搜索文字, 局变搜索文字, 局变位置 + 1, 假)
  32. .如果真 (局变位置 ≠ -1)
  33. 跳出循环 ()
  34. .如果真结束
  35. .计次循环尾 ()
  36. .如果真 (局变位置 ≠ -1)
  37. 到循环尾 ()
  38. .如果真结束
  39. .如果真 (寻找文本 (局变被搜索文字, 到文本 (0), , 假) ≠ -1)
  40. 到循环尾 ()
  41. .如果真结束
  42. 调试输出 (数组1 [n1], 数组2 [n1], 数组3 [n1])
  43. .如果真结束
  44. .计次循环尾 ()

[文件] 爆破 解决数学题.zip ~ 20KB    下载

2.20后续 优化了下的版本~~、 减少了3个变量与两个记次循环


  1. .版本 2
  2. .支持库 spec
  3. .程序集 窗口程序集1
  4. .程序集变量 数组1, 整数型, , "0"
  5. .程序集变量 数组2, 整数型, , "0"
  6. .程序集变量 数组3, 整数型, , "0"
  7. .子程序 _按钮1_被单击
  8. .局部变量 局变被搜索文字, 文本型
  9. .局部变量 局变位置, 整数型
  10. .局部变量 t1, 整数型
  11. .局部变量 m1, 整数型
  12. .计次循环首 (999, t1)
  13. 加入成员 (数组1, t1)
  14. 加入成员 (数组2, t1 × 2)
  15. 加入成员 (数组3, t1 × 3)
  16. .如果真 (数组1 [t1] < 123)
  17. 到循环尾 ()
  18. .如果真结束
  19. .如果真 (数组1 [t1] × 2 = 数组2 [t1] 且 数组1 [t1] × 3 = 数组3 [t1])
  20. 局变被搜索文字 = 到文本 (数组1 [t1]) + 到文本 (数组2 [t1]) + 到文本 (数组3 [t1])
  21. .计次循环首 (10, m1)
  22. 局变位置 = 寻找文本 (局变被搜索文字, 到文本 (m1 - 1), , 假)
  23. 局变位置 = 寻找文本 (局变被搜索文字, 到文本 (m1 - 1), 局变位置 + 1, 假)
  24. .如果真 (局变位置 ≠ -1)
  25. 跳出循环 ()
  26. .如果真结束
  27. .计次循环尾 ()
  28. .如果真 (局变位置 ≠ -1)
  29. 到循环尾 ()
  30. .如果真结束
  31. .如果真 (寻找文本 (局变被搜索文字, 到文本 (0), , 假) ≠ -1)
  32. 到循环尾 ()
  33. .如果真结束
  34. 调试输出 (数组1 [t1], 数组2 [t1], 数组3 [t1])
  35. .如果真结束
  36. .计次循环尾 ()

用云栖社区APP,舒服~

【云栖快讯】诚邀你用自己的技术能力来用心回答每一个问题,通过回答传承技术知识、经验、心得,问答专家期待你加入!  详情请点击

网友评论

cometwo123
文章2699篇 | 关注27
关注
预置千套精美模板,覆盖上百行业,模板随意切换,支持6种语言,支持企业备案 查看详情
用配置管理(Application Configuration Management,简称 ... 查看详情
是基于语音识别、语音合成、自然语言理解等技术,为企业在多种实际应用场景下,赋予产品“能听、会... 查看详情
为您提供简单高效、处理能力可弹性伸缩的计算服务,帮助您快速构建更稳定、安全的应用,提升运维效... 查看详情
阿里云总监课正式启航

阿里云总监课正式启航