九度1464:Hello World for U

简介:

题目1464:Hello World for U
时间限制:1 秒
内存限制:128 兆
特殊判题:否
提交:2967
解决:834
题目描述:
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
e     l
l      r
lowo


That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:
There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:
For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com样例输出:
h      !
e     d
l       l
lowor
a    m
c      o
.       c
jobdu.

来源:
2012年浙江大学计算机及软件工程研究生机试真题

 

思路:注意"n1 + n2 + n3 - 2 = N.",最好将n1,n2,n3都取得平均值,即n1=n2=(n+2)/3-1

#include<stdio.h>
#include<string.h>
char a[100];
int main()
{
    int i,j,n,n1,n2,n3,m1,m2;
    while(scanf("%s",a)!=EOF)
    {
       n=strlen(a);
    n1=n2=(n+2)/3-1;
    n3=n-2*n1;
    for(i=0;i<n1;i++)
    {
          printf("%c",a[i]);
    for(j=0;j<n3-2;j++)
     printf(" ");
    printf("%c\n",a[n-i-1]);
    }
    m1=i;m2=n-i;
    for(i=m1;i<m2;i++)
     printf("%c",a[i]);
    puts("");
       memset(a,0,sizeof(0));
    }
    return 0;
}
相关文章
|
20天前
|
存储 程序员 C语言
【C++】“Hello World!“
【C++】“Hello World!“
22 3
|
2月前
|
移动开发 C++
Hello World
Hello World
16 0
10:Hello, World!的大小
10:Hello, World!的大小
63 0
01:Hello, World!
01:Hello, World!
70 0
|
C++
L1-001 Hello World
文章目录 L1-001 Hello World (5 分) 总结
77 0
L1-001 Hello World
Hello world
首帖则测试了解下如何使用,并且看看有什么不同的地方,是不是很好用呢 引用测试 H是什么不知道
536 0
|
Java 设计模式 Android开发
虐心,Hello World
前言 无意中在知乎上看到了一个很有意思的回答:https://www.zhihu.com/question/277243683/answer/393676961题目是:如何把一段简单的代码变复杂? 答主的回答当然是为了调侃。
1375 0
|
Java
你真的会写Hello World吗
概要 起因A3项目发展2年后,功能较为稳定后 ,准备合并进EagleEye主体项目,遇到了个问题,代码很难merge进EagleEye。暴露了一个问题,代码写得太差。模块化。重新认识一下,如何写代码 入门版Hello World 下面这段经典代码,开始学习的时候,觉得非常的优美。
2577 0