【JAVA大数训练】A + B Problem II

简介:

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 196702    Accepted Submission(s): 37626


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each

line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process

them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second

line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a

blank line between two test cases.

 

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 


 

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
 public static void main(String[] args) {
  Scanner input=new Scanner(System.in);
  int n=input.nextInt();
  int k=1;
  while(n!=0)
  {
   BigInteger a=input.nextBigInteger();
   BigInteger b=input.nextBigInteger();
      BigInteger c=a.add(b);
                    n--;
      if(k!=1)
       System.out.println();//输出换行
            System.out.println("Case "+k+":");
            k++;
      System.out.println(a+" + "+b+" = "+c);
  }
 }
}
相关文章
|
20天前
|
Java 编译器
有关电脑中idea编译报错问题java: No implementation was created for AdminUserConverter due to having a problem in
有关电脑中idea编译报错问题java: No implementation was created for AdminUserConverter due to having a problem in
28 0
java.lang.Error: Unresolved compilation problem: The type List is not generic; it cannot be parame
java.lang.Error: Unresolved compilation problem: The type List is not generic; it cannot be parame
|
6月前
|
Cloud Native Java Go
解决 Spring Boot 和 Gradle Java 版本兼容性问题:A problem occurred configuring root project ‘demo1‘. > Could n
解决 Spring Boot 和 Gradle Java 版本兼容性问题:A problem occurred configuring root project ‘demo1‘. > Could n
360 0
|
8月前
|
Java
Java 中大数的处理方案BigInteger和BigDecimal类的使用
Java 中大数的处理方案BigInteger和BigDecimal类的使用
50 0
|
8月前
|
Java C语言
逻辑训练--经典汉诺塔问题(C和JAVA递归实现)
逻辑训练--经典汉诺塔问题(C和JAVA递归实现)
|
10月前
|
Java
蓝桥杯 入门训练 Fibonacci数列 (Java)
蓝桥杯 入门训练 Fibonacci数列 (Java)
59 0
|
10月前
|
Java
蓝桥杯 入门训练 圆的面积(Java)
蓝桥杯 入门训练 圆的面积(Java)
52 0
|
10月前
|
Java
蓝桥杯 入门训练 序列求和 (Java)
蓝桥杯 入门训练 序列求和 (Java)
60 0
|
11月前
|
Java
Java从新手到大牛,如何训练?
Java从新手到大牛,如何训练?
|
Java 索引
java中大数的计算BigInteger和BigDecimal两个类的常用方法
java中大数的计算BigInteger和BigDecimal两个类的常用方法
70 0