【JAVA大数训练】How Many Fibs?

简介:

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3628    Accepted Submission(s): 1457


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 

Sample Input
 
 
10 100 1234567890 9876543210 0 0
 

Sample Output
 
 
5 4
 

Source
 

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		BigInteger [] p=new BigInteger[10010];
        p[1]=BigInteger.valueOf(1);p[2]=BigInteger.valueOf(2);
		for (int i = 3; i<=10000; i++) {
			p[i]=p[i-1].add(p[i-2]);
		}
		while(input.hasNext())
		{
			BigInteger n=input.nextBigInteger();
			BigInteger m=input.nextBigInteger();
			int sum=0;
			if(n.compareTo(BigInteger.ZERO)==0&&m.compareTo(BigInteger.ZERO)==0)
			break;
			for (int i = 1; i <=10000; i++) {
				if(p[i].compareTo(n)>=0&&p[i].compareTo(m)<=0)
					sum++;
			}
		    System.out.println(sum);
		}
	}
}


 

总结

BigIngter a与BigIngter b比大小

如果a比b大

a.compareTo(b)>0

如果a比b小

a.compareTo(b)<0

如果a等于b

a.compareTo(b)==0

 

相关文章
|
8月前
|
Java
Java 中大数的处理方案BigInteger和BigDecimal类的使用
Java 中大数的处理方案BigInteger和BigDecimal类的使用
51 0
|
8月前
|
Java C语言
逻辑训练--经典汉诺塔问题(C和JAVA递归实现)
逻辑训练--经典汉诺塔问题(C和JAVA递归实现)
|
10月前
|
Java
蓝桥杯 入门训练 Fibonacci数列 (Java)
蓝桥杯 入门训练 Fibonacci数列 (Java)
59 0
|
10月前
|
Java
蓝桥杯 入门训练 圆的面积(Java)
蓝桥杯 入门训练 圆的面积(Java)
53 0
|
10月前
|
Java
蓝桥杯 入门训练 序列求和 (Java)
蓝桥杯 入门训练 序列求和 (Java)
62 0
|
11月前
|
Java
Java从新手到大牛,如何训练?
Java从新手到大牛,如何训练?
|
Java 索引
java中大数的计算BigInteger和BigDecimal两个类的常用方法
java中大数的计算BigInteger和BigDecimal两个类的常用方法
70 0
HDU-1002,A + B Problem II(Java大数)
HDU-1002,A + B Problem II(Java大数)
|
Java Python
Java大数BigInteger-用法记录
Java大数BigInteger-用法记录 提交代码 使用方式 构造一个对象 加 add 减 subtract 乘 multiply 除 divide gcd 最大公约数 lcm 最小公倍数 mod % pow ^次方 abs 绝对值 开方sqrt modPow 次方取余 equals判断是否相等 compareTo 比较大小 常用的就上面这些啦
347 0
Java大数BigInteger-用法记录
|
Java
java核心技术卷I中的细节(2- 大数)
java核心技术卷I中的细节(2- 大数)
91 0
java核心技术卷I中的细节(2- 大数)

热门文章

最新文章