【端午小练】HDU1701-ACMer

简介:

ACMer
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3533    Accepted Submission(s): 1627


Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

Output
For each test case, output the minumal number of students in HDU.
 

Sample Input
1
13.00 14.10
 

Sample Output
15
 

Source
2007省赛集训队练习赛(1)
 

 

/*题意:就是给你两个double的 数据 A B 
让你求一个int 数  i  满足  i*A与i*B之间只夹一个数
也就是题目中的ACMER  而此i既是所求的student*/
AC代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,T;
    double n,m;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%lf %lf",&n,&m);
       for(i=1;;i++)
       {
            if(int(m*i*0.01)-int(n*i*0.01)==1)
    break;
       }
       printf("%d\n",i);
    }
    return 0;
}
相关文章
|
11月前
|
算法 C++ Python
【每日算法Day 87】今天我脱单了,所以大家不用做题了!
【每日算法Day 87】今天我脱单了,所以大家不用做题了!
|
索引
每日一题——山羊拉丁文
每日一题——山羊拉丁文
79 0
每日一题——山羊拉丁文
|
移动开发
2021牛客国庆集训派对day1 J.Different Integers(莫队)
2021牛客国庆集训派对day1 J.Different Integers(莫队)
69 0
HDU-2897,邂逅明下(巴什博弈)
HDU-2897,邂逅明下(巴什博弈)
|
算法
HDU - 2063: 过山车
HDU - 2063: 过山车
109 0
|
人工智能 测试技术