HDU4772-Zhuge Liang's Password

简介:

Zhuge Liang's Password
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 541    Accepted Submission(s): 370


Problem Description
  In the ancient three kingdom period, Zhuge Liang was the most famous and smart military leader. His enemy was Sima Yi, the military leader of Kingdom Wei. Sima Yi always looked stupid when fighting against Zhuge Liang. But it was Sima Yi who laughed to the end.
  Zhuge Liang had led his army across the mountain Qi to attack Kingdom Wei for six times, which all failed. Because of the long journey, the food supply was a big problem. Zhuge Liang invented a kind of bull-like or horse-like robot called "Wooden Bull & Floating Horse"(in abbreviation, WBFH) to carry food for the army. Every WBFH had a password lock. A WBFH would move if and only if the soldier entered the password. Zhuge Liang was always worrying about everything and always did trivial things by himself. Since Ma Su lost Jieting and was killed by him, he didn't trust anyone's IQ any more. He thought the soldiers might forget the password of WBFHs. So he made two password cards for each WBFH. If the soldier operating a WBFH forgot the password or got killed, the password still could be regained by those two password cards.
  Once, Sima Yi defeated Zhuge Liang again, and got many WBFHs in the battle field. But he didn't know the passwords. Ma Su's son betrayed Zhuge Liang and came to Sima Yi. He told Sima Yi the way to figure out the password by two cards.He said to Sima Yi:
  "A password card is a square grid consisting of N×N cells.In each cell,there is a number. Two password cards are of the same size. If you overlap them, you get two numbers in each cell. Those two numbers in a cell may be the same or not the same. You can turn a card by 0 degree, 90 degrees, 180 degrees, or 270 degrees, and then overlap it on another. But flipping is not allowed. The maximum amount of cells which contains two equal numbers after overlapping, is the password. Please note that the two cards must be totally overlapped. You can't only overlap a part of them."
  Now you should find a way to figure out the password for each WBFH as quickly as possible.
 

Input
  There are several test cases.
  In each test case:
  The first line contains a integer N, meaning that the password card is a N×N grid(0<N<=30).
  Then a N×N matrix follows ,describing a password card. Each element is an integer in a cell.
  Then another N×N matrix follows, describing another password card.
  Those integers are all no less than 0 and less than 300.
  The input ends with N = 0
 

Output
  For each test case, print the password.

 

Sample Input
2
1 2
3 4
5 6
7 8
2
10 20
30 13
90 10
13 21
0
 

Sample Output
0
2
 

Source
2013 Asia Hangzhou Regional Contest
 

//矩阵旋转
AC代码:

#include<stdio.h>
#include<string.h>
int a[40][40],b[40][40];
void Rotate(int n)
{
 int i,j,c[40][40],x=0,y=n-1;
    for(i=0;i<n;i++)
  for(j=0;j<n;j++)
  {
            c[i][j]=b[x++][y];
   if(x>n-1)
   {
                x=0;y--;
   }
  }

 for(i=0;i<n;i++)
  for(j=0;j<n;j++)
  {
   b[i][j]=c[i][j];
  }
}
int main()
{
 int i,j,n,m,sum,max;
 while(scanf("%d",&n),n!=0)
 {
  memset(a,0,sizeof(a));
  memset(b,0,sizeof(b));
  max=0;
  for(i=0;i<n;i++)
  for(j=0;j<n;j++)
   scanf("%d",&a[i][j]);
        for(i=0;i<n;i++)
  for(j=0;j<n;j++)
   scanf("%d",&b[i][j]);
        
  sum=0;
  for(i=0;i<n;i++)
  for(j=0;j<n;j++)
  {
   if(a[i][j]==b[i][j])
    sum++;
  }
  if(sum>max)
   max=sum;
       
  int T=3;
  while(T--)
  {
            Rotate(n);
   sum=0;
            for(i=0;i<n;i++)
   for(j=0;j<n;j++)
   {
    if(a[i][j]==b[i][j])
     sum++;
   }
   if(sum>max)
    max=sum;
  }
  printf("%d\n",max);
 }
 return 0;
}
相关文章
|
5月前
|
Java Go
hdu 1216 Assistance Required
hdu 1216 Assistance Required
20 0
|
7月前
BUUCTF password 1
BUUCTF password 1
102 0
|
10月前
|
数据安全/隐私保护 C++
【PAT甲级 - C++题解】1035 Password
【PAT甲级 - C++题解】1035 Password
41 0
|
数据安全/隐私保护
password题解
password题解
59 0
password题解
【1035】Password (20 分)
【1035】Password (20 分) 【1035】Password (20 分)
88 0
|
索引
1035. Password (20)
To prepare for PAT, the judge sometimes has to generate random passwords for the users.
955 0
|
数据安全/隐私保护 网络架构 网络安全
|
数据安全/隐私保护 网络架构 网络安全
|
数据安全/隐私保护