HDU1050-Moving Tables

简介:

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19290    Accepted Submission(s): 6585

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

 

 

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

 

 

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

 

 

Sample Input

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

 

 

Sample Output

10

20

30

 

 

Source

Asia 2001, Taejon (South Korea)

 

 

 

 

//思路:贪心算法,区间覆盖

1.区间覆盖

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
   int x,y;     
}a[210];
int sum[210];
int main()
{
    int i,j,n,m,t,max;
    scanf("%d",&m);
    while(m--)
    {
       scanf("%d",&n);
       memset(sum,0,sizeof(sum));
       for(i=0;i<n;i++)
       {
          scanf("%d %d",&a[i].x,&a[i].y);
          a[i].x=(a[i].x+1)/2;
          a[i].y=(a[i].y+1)/2;
          if(a[i].x>a[i].y)//桌子可能从大房间号移到小房间号
          {
             t=a[i].x;
             a[i].x=a[i].y;
             a[i].y=t;
          }
          for(j=a[i].x;j<=a[i].y;j++)//覆盖区间 
          sum[j]++;
       }
       sort(sum,sum+210);
       printf("%d\n",sum[209]*10);
    }
    return 0;
}

注意:

/*1 3

4 5

20分钟

 

1 4

5 6

10分钟*/

相关文章
|
5月前
|
图形学
hdu1086 You can Solve a Geometry Problem too(判断线段相交)
hdu1086 You can Solve a Geometry Problem too(判断线段相交)
27 0
|
8月前
UVa11565 - Simple Equations
UVa11565 - Simple Equations
35 0
|
8月前
uva101 The Blocks Problem
uva101 The Blocks Problem
31 0
|
算法 Python
LeetCode 283. 移动零 Move Zeroes
LeetCode 283. 移动零 Move Zeroes
LeetCode 283. Move Zeroes
给定一个数组 nums,编写一个函数将所有 0 移动到数组的末尾,同时保持非零元素的相对顺序。
62 0
LeetCode 283. Move Zeroes
杭电oj-1050 Moving Tables
杭电oj-1050 Moving Tables
78 0
杭电oj-1050 Moving Tables
|
算法
HDU-1050,Moving Tables(不用贪心也AC)
HDU-1050,Moving Tables(不用贪心也AC)
LeetCode之Move Zeroes
LeetCode之Move Zeroes
80 0
|
索引 Python Java
LeetCode 283:移动零 Move Zeroes
给定一个数组 nums,编写一个函数将所有 0 移动到数组的末尾,同时保持非零元素的相对顺序。 Given an array nums, write a function to move all 0's to the end of it while maintaining the relative order of the non-zero elements. 示例: 输入: [0,1,0,3,12] 输出: [1,3,12,0,0] 说明: 必须在原数组上操作,不能拷贝额外的数组。
742 0