hdu3501

简介:


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 


Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 


Output
For each test case, you should print the sum module 1000000007 in a line.
 


Sample Input
 
 
3 4 0
 


Sample Output
 
 
0 2
代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
const int mod=1000000007;
int phi(long long m)
{
    long long  rea=m;
    for(long long  i=2;i*i<=m;i++)
     {
         if(m%i==0)
         rea-=rea/i;
         while(m%i==0)
         m/=i;
     }
     if(m>1)
        rea-=rea/m;
     return rea;
}
int main()
{
    /*欧拉函数一个小小的性质:
    求小于n并且与n互质的数的和为:m*phi[m]/2;*/
    long long  m,ans;
    while(~scanf("%lld",&m))
     {
         if(m==0)break;
         ans=phi(m);
         ans=(m*(m-1)/2-m*ans/2)%mod;
         printf("%lld\n",ans);
     }
    return 0;
}#include <iostream>
#include <cstdio>
using namespace std;
const int mod=1000000007;
int phi(long long m)
{
long long rea=m;
for(long long i=2;i*i<=m;i++)
{
if(m%i==0)
rea-=rea/i;
while(m%i==0)
m/=i;
}
if(m>1)
rea-=rea/m;
return rea;
}
int main()
{
/*欧拉函数一个小小的性质:
求小于n并且与n互质的数的和为:n*phi[n]/2;*/
long long m,ans;
while(~scanf("%lld",&m))
{
if(m==0)break;
ans=phi(m);
ans=(m*(m-1)/2-m*ans/2)%mod;
printf("%lld\n",ans);
}
return 0;
}

目录
相关文章
|
人工智能 Java
2021杭电多校5-Arrary-hdu7020
Array Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others) Total Submission(s): 965 Accepted Submission(s): 312 Problem Description Given an integer array a[1…n].
137 0
2021杭电多校5-Arrary-hdu7020
|
机器学习/深度学习 Java 算法
HDU 2549 壮志难酬
壮志难酬 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 12541    Accepted Submission(s): 4166 Problem Description 话说MCA山上各路豪杰均出山抗敌,去年曾在江湖威名显赫的,江湖人称的甘露也不甘示弱,“天将降大任于斯人也,必先劳其筋骨,饿其体肤,空乏其身”他说。
1002 0
|
Java BI
HDU 2034 人见人爱A-B
人见人爱A-B Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 77157    Accepted Submission(s): 21509 Problem Description 参加过上个月月赛的同学一定还记得其中的一个最简单的题目,就是{A}+{B},那个题目求的是两个集合的并集,今天我们这个A-B求的是两个集合的差,就是做集合的减法运算。
1121 0
|
机器学习/深度学习
|
机器学习/深度学习